Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Найти все значения, удовлетворяющие условию
 
Добрый день. Мне нужно, чтобы формула отобразила сначала 1 значение по условию, потом следующее.
Прикрепил пример.
У меня есть готовая формула, которая может находить значение, согласно условию.
Но если по этому условию есть 2 значения, то второе значение формула уже не может отобразить. Прошу вас помочь с этим.
Условием является столбец С, Столбцы С8:С9 и С11:С12 повторяются, а значит в ячейке D8:D9 и D11:D12 должно быть по 2 отличающихся друг от друга значения, но у меня это сделать не получилось.

Спасибо.
 
Цитата
RamRiz написал:
чтобы формула отобразила сначала 1 значение по условию, потом следующее.
Покажите вручную, где и как это нужно отобразить.
 
Добрый день! Как вариант.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист4!$B$3:$B$27;АГРЕГАТ(15;6;(СТРОКА(Лист4!$C$3:$C$27)-2)/(Лист4!$C$3:$C$27=Лист1!C2);СЧЁТЕСЛИ($C$2:C2;C2)));"Нет")


и в приемах можно посмотреть
Изменено: Stics - 17 июл 2020 21:12:10
 
Цитата
Михаил Витальевич С. написал:
Покажите вручную, где и как это нужно отобразить.
В Листе 1 обратите внимание на D9. и D12 . Посмотрите по формуле, условием формулы являются C9 = Киргу М и C12 = Импульс. Значение ячейки C9 совпадает с значением ячейки C8, также и по C12 и C11. Из-за этого D9=D8,а D12=D11. Но так не должно быть.

Откройте Лист 4, и вы увидите что на ТТ "Импульс" и "Киргу" работают по 2 сотрудника. Мне нужно, чтобы в D9 и D12 отображалось фио 2й пары сотрудников.
 
RamRiz, мой вариант смотрели?
 
Класс, работает) Спасибо большое.
У вас формула сложней чем у меня. Попробую в ней разобраться.
 
начните с материала в Приемах
 
Ок спасибо, там куча полезной инфы)
 
RamRiz, еще вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист4!$B$3:$B$27;ПОИСКПОЗ(1;ИНДЕКС((СЧЁТЕСЛИ(D$1:D1;Лист4!$B$3:$B$27)=0)/(Лист4!$C$3:$C$27=Лист1!C2);0);0));"нет")
Не бойтесь совершенства. Вам его не достичь.
 
Mershik, здесь уже используются знакомые мне формулы. Спасибо за второй вариант.
Страницы: 1
Читают тему (гостей: 1)
Наверх