Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Показать самую раннюю дату поставки по конкретному сочетанию "Артикул+Серийный номер"
 
Добрый день! Понимаю, что решение должно быть достаточно простым (хотя порой, если так кажется, формула получается на выходе огромной), но никак не могу сообразить, каким именно. Помогите, пожалуйста!

Имеется ряд артикулов, по каждому из которых есть некоторое число серийных номеров. Причём одни и те же серийные номера могут рандомно повторяться у разных артикулов. Также есть данные по датам поставки каждой позиции (Артикул+Серийник). Одна и та же позиция (Артикул+Серийник) может поставляться несколько раз.
Задача: показать в строке, соответствующей дате ПЕРВОЙ поставки этой позиции (Артикул+Серийник), собственно эту самую дату; остальные строки должны быть пустыми (именно пустыми, т.к. с таблицей будут работать несведущие сотрудники, которые случайно текст белым шрифтом могут углядеть и с ним начать работать)

Задача и сама табличка, возможно, "неизящные", но суть такая, скорее всего, далее доработаю ещё форму представления, в т.ч. подключив условное форматирование.

Заранее благодарю!
 
Почему бы не отсортировать по датам по восходящей, и тянуть хоть с помощью ВПР, хоть ИНДЕКС+ПОИСКПОЗ
 
Катя, ДД. так как нет желаемого результата в файле...как понял
Код
=ЕСЛИ(СЧЁТЕСЛИМН($A$1:A1;A2;$C$1:C1;C2)>=1;"";АГРЕГАТ(15;6;$D$2:$D$13/($A$2:$A$13=$A2)/($C$2:$C$13=$C2);1))
Не бойтесь совершенства. Вам его не достичь.
 
Цитата
Катя написал:
строки должны быть пустыми (именно пустыми
т.е. формульное решение не принимается? или это просто фигура речи?
Код
=ЕСЛИ(МИНЕСЛИ($D$2:$D$13;$A$2:$A$13;A2;$C$2:$C$13;C2)=D2;D2;"")
Каждому For свой Next
 
Большое спасибо за помощь! Не знакома с функциями СЧЁТЕСЛИМН, АГРЕГАТ и МИНЕСЛИ, буду изучать все предложенные варианты формул, применяя уже к оригинальному файлу :)  
Страницы: 1
Читают тему (гостей: 1)
Наверх