Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ссылка на ближайшую непустую ячейку
 
Добрый день!
Подскажите пожалуйста, как в ячейке прописать формулу - в виде ссылки на ближайшую (слева) ячейку с непустым значением. Чтобы эту формулу можно было протянуть на другие соседние ячейки, и в них она ссылалась бы на свои ближайшие слева непустые значения.
Спасибо.
 
Если правильно поняла
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;B$2:$B2);"")
 
Pelena, спасибо!

Единственное, в Вашей формуле в массиве ПРОСМОТР сдвинул правую ячейку диапазона на 1 ячейку влево, чтобы в результате сама ячейка не ссылалась на  себя как на ближайшую слева.
 
Ну, это Вам виднее)
Страницы: 1
Читают тему (гостей: 1)
Наверх