Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Отделить номер дома от названия улицы
 
Есть вот такие адреса, и не могу  разделить на разные колонки текст и число, помогите пожалуйста
Russikerstrasse 29
Malzmattstrasse 34
Hinwilerstrasse 22
Gabelacher 6
Buchenweg 7a
Obere Heslibachstrasse 85a
Obergreuel 1
Riedmattweid
Gässli 4
Salensteinerstrasse 10c
Brambergstrasse 6
Wybergliweg 64
Würzenbachstrasse 75
Sack 1
 
=ЛЕВБ(A2;ПОИСК(" ";A2)-1)
Но не сработает, если число не перед первым пробелом. А писать другое без примера... оно помогающим надо или Вам?
 
Код
=СЖПРОБЕЛЫ(ПРАВБ(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";99));99))
но не будет работать, если номера дома вообще нет
Каждому For свой Next
 
vikttur,Мне нужно, просто разные нюансы с пробелами  и с числами, и не могу придумать что делать  
 
Если Вам нужно, но пример нормальный показывать не хотите, то ручками, ручками...
 
В  ячейке Е должен оставаться только текст,  когда  формула делает поиск  в  D ячейке где нету  цифр выбивает ошибку.
А в F только  номер дома должен остаться,  а  когда  формула делает поиск  в  D ячейке то копирует  просто текст. ПОМОГИТЕ ПОЖАЛУЙСТА, БУДУ ПРИЗНАТЕЛЕН
 
Добрый день, массивные:
=ПСТР(D2;1;ЕСЛИ(МИН(ЕСЛИОШИБКА(ПОИСК({1;2;3;4;5;6;7;8;9;0};D2);""))=0;ДЛСТР(D2);МИН(ЕСЛИОШИБКА(ПОИСК({1;2;3;4;5;6;7;8;9;0};D2);""))-1))
=ЕСЛИОШИБКА(ПСТР(D2;МИН(ЕСЛИОШИБКА(ПОИСК({1;2;3;4};D2);""));99);"")
 
Юрий Назаров, попробуйте Данные - Текст по столбцам.
Excel непознаваем как атом.
 
Настя_Nastya, спасибо Вам огромное, правда выручили)))) я не могу понять почему  не проходят некоторые парные цифры, с этих двух цифр только одна выводится  
 
Ой, пардон-пардон!!! Вторая формула массива:
=ЕСЛИОШИБКА(ПСТР(D2;МИН(ЕСЛИОШИБКА(ПОИСК({1;2;3;4;5;6;7;8;9;0};D2);""));99);"")
 
если сначала применить вторую формулу Настя_Nastya, то привязавшись к полученным данным первой формулой можно использовать такую
Код
=ПОДСТАВИТЬ(D2;F2;"")
Лень двигатель прогресса, доказано!!!
 
=ЛЕВБ(D2;МИН(ПОИСК({1;2;3;4;5;6;7;8;9;0};D2&" "&1234567890))-2)
=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(D2;E2;))
 
Настя_Nastya,Спасибо Большое, правда очень помоги!!! Хорошего Вам дня
Страницы: 1
Читают тему (гостей: 1)
Наверх