Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Копирование строки, номер которой указан в ячейке, VBA Макрос
 
Имеется таблица в каждой строке в столбце АА указан номер строки откуда необходимо скопировать диапазон значений (от R до X) вместе с форматированием, если в ячейке указан "0" то не копировать, подскажите какую формулу применить. Пример во вложении (пробовал Индексами сделать не сработало)
 
Код
=ИНДЕКС(R:R;$AA$1)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
А можете подсказать почему мой Индекс не работал?
 
ваш индексы выходилы за пределы диапазона
не возможно из массива  данных размером в 2 строки 1 колонка получить значение из 3-й строки 22 колонки
в массиве 2х1 нет ни 3-й строки, ни тем более 22 колонки
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Понял спасибо, остался момент, как можно не копировать строку если значение в ячейке "0"? И собственно сохранить форматирование ячейки
Изменено: Василька - 5 авг 2020 14:49:37
 
Код
=если($AA$1=0;"";ИНДЕКС(R:R;$AA$1))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 1)
Наверх