Страницы: 1
RSS
Сумма за текущий месяц по сегодня (включительно), В постоянно дополняющейся таблице нужно вывести сумму за текущий месяц по сегодняшний день
 
Здравствуйте! Помогите, пожалуйста, посчитать сумму в столбце "B" только за текущий месяц по сегодняшний день включительно (не учитывая будущие даты).
 
?
Код
=СУММЕСЛИМН(B:B;A:A;">="&КОНМЕСЯЦА(СЕГОДНЯ();-1)+1;A:A;"<="&СЕГОДНЯ())
Лень двигатель прогресса, доказано!!!
 
Громоздче, но все-же как вариант:
Англ.
Код
=SUMPRODUCT(($B$2:$B$50)*($A$2:$A$50>=TODAY()-DAY(TODAY())+1)*($A$2:$A$50<=TODAY()))

Рус.
Код
=СУММПРОИЗВ(($B$2:$B$50)*($A$2:$A$50>=СЕГОДНЯ()-ДЕНЬ(СЕГОДНЯ())+1)*($A$2:$A$50<=СЕГОДНЯ()))
 
Еще, как вариант:
Код
=СУММЕСЛИМН(B2:B50;A2:A50;">="&ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ());1);A2:A50;"<="&СЕГОДНЯ())
 
Спасибо за помощь!
Страницы: 1
Читают тему (гостей: 1)
Наверх