Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Получить разницу между текущим значением и значением из предыдущей заполненной ячейки в этом же столбце
 
Вечер добрый! Помогите с вычитанием. В столбец А заполняются данные счетчика, с увеличением, в В разница двух показаний, загвоздка в том, что в столбец А данные в строки вводятся произвольно с пропуском строк. как написать формулу, чтобы не учитывать пустые ячейки, а вычитаемое бралось из последней заполненной строки
 
назание темы
как получить разницу между текущим значением и значением из предыдущей заполненной ячейки в этом же столбце
ответ:
Код
=ЕСЛИ(НЕ(ЕПУСТО(B3));B3-ПРОСМОТР(99^99;$B$1:B2);"")
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Огромное спасибо, очень выручили!
Страницы: 1
Читают тему (гостей: 1)
Наверх