Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вывести первое значение, дубликаты игнорировать
 
Здраствуйте. Помогите пожалуйста.
Есть таблица, нужно заполнить только первую строчку, остальные дубликаты оставить пустими как показано в примере. ВПР - дублирует суммы.
Решение можна или формулой, или в PQ (это идеальный вариант)
Есть справочник из сумами, из нее берем сумму.
Снимок.PNG (12.58 КБ)
Изменено: Александр* - 19 окт 2020 16:33:10
 
Цитата
Александр* написал:
Есть справочник из сумами, из нее берем суму.

"сумма" лучше писать с 2 "м"
Изменено: New - 19 окт 2020 16:26:26
 
Если протоколы идут блоками, то можно так:
=ЕСЛИ(A3<>A2;ВПР(A3;E$3:F$4;2;);"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Вариант с формулами.
 
Всем спасибо.
 
Цитата
New написал:
"сумма" лучше писать с 2 "м"
Исправил. Спасибо)
 
Цитата
Есть справочник из сумами, из нее берем сумму.
Код
Sub Сума()
Dim i As Long
Dim iLastRow As Long
Dim FoundCell As Range
  iLastRow = Cells(Rows.Count, "A").End(xlUp).Row
  Range("B3:B" & iLastRow).ClearContents
  iLastRow = Cells(Rows.Count, "E").End(xlUp).Row
 For i = 3 To iLastRow
    Set FoundCell = Columns(1).Find(Cells(i, "E"), , xlValues, xlWhole)
     If Not FoundCell Is Nothing Then
       FoundCell.Offset(, 1) = Cells(i, "F")
     End If
 Next
End Sub
 
Цитата
Александр* написал:
или в PQ (это идеальный вариант)
Можно и в нем, родимом:
Код
let
    Source1 = Excel.CurrentWorkbook(){[Name="Таблица2"]}[Content][[#"Протокол №"]],
    Source2 = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    MergedQueries = Table.NestedJoin(Source2, {"Протокол №"}, Source1, {"Протокол №"}, "Source2", JoinKind.FullOuter),
    AddedCustom = Table.AddColumn(MergedQueries, "Tab", each Table.FromColumns({[Source2][#"Протокол №"], {[Сумма]}},Table.ColumnNames(Source2) ) ),
    Tab = Table.Combine( AddedCustom[Tab] )
in
    Tab
Вот горшок пустой, он предмет простой...
 
Цитата
PooHkrd написал:
Можно и в нем, родимом:
Идеально.
Спасибо Вам огромное
 
Kuzmich, очень Вам благодарен
Страницы: 1
Читают тему (гостей: 1)
Наверх