Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Взять данные из одного файла, и подставить в другой, формулой
 
Есть два файла, нужно в файл во вложении Книга1. Вставить данные из файла реестр инвойсов BL date, чтобы это все сделалось автоматически.
Изменено: DJMC - 27 окт 2020 11:08:32
 
И чем вам ВПР() не нравится?
 
ВПР я сделал, но не пойму как добавлять именно значение

=ЕСЛИОШИБКА(ВПР(D2;$A$2:$A$3105;1;ЛОЖЬ);"Контрагент отсутствует")

тут D2 - то что ищем
;$A$2:$A$3105; - интервал
 
Цитата
DJMC написал:
$A$2:$A$3105; - интервал
так здесь разве не диапазон из другой книги должен быть? или что Вам получить-то надо?
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Все решил сам, вот такой формулой
Цитата
=ВПР(C2;$A$1:$C$3085;2;ЛОЖЬ)
спасибо за подсказку с ВПР
 
Кто ни будь может подсказать где ошибка в формуле?
мне нужно заполнить столбец Delivery port
ввел формулу =ВПР(A2;$A$2:$H$878;7;ЛОЖЬ) но она работает не корректно, берет не те данные..
то есть в первой строчке значение 587769410 она берет почему то SPOT Bremen, хотя если запустить поиск  по 587769410, должно браться значение из строчки 398 Ho Chi Minh City, VN.

Не пойму почему так происходит, такая проблема со всеми занчениями.
Изменено: DJMC - 27 окт 2020 11:52:20
 
Неправильная формула.
В каком столбце надо искать значение А2?? тк значение  587769410 есть в 3х столбцах (Н398,А2,Е167).
 
Окончательно запутался в формулах, прошу помощи гуру ВПР, файл во вложении.
В столбце  A - коносамент внесены номера, нужно найти эти номера в столбце  F - BL # и поставить данные из столбца G - BL date в графу С - BL dat
Потом тоже самое сделать со столбцом H -  "Planned PD Delivery port" и вставить эти данные в столбец E "Delivery port"


важный момент в столбец А2 значение  MEDUVT379561 нужно взять верную дату из столбца F2320   = 20.11.2019
 
DJMC, вы ставите столбец №7 - но это номер столбца в таблице указанного диапазона - почитайте справку функции ВПР. т.е. замените 7 на 2
а не находит ваше MEDUVT379561 - потому что в одном списке написано просто, а в другом с кучей пробелов после  
Снимок.JPG (13.13 КБ)
Изменено: Mershik - 27 окт 2020 14:25:35
Не бойтесь совершенства. Вам его не достичь.
 
Спасибо, наверное самое разумное тут на листы разделить задачу.

Код
=ВПР(A2;Лист3!$A$2:$B$2839;2;ЛОЖЬ)
 
вместо ЛОЖЬ можете писать цифру ноль (0)
 
...или ничего не писать
 
А если ничего не писать - а не будет ли тогда
Код
=ВПР(A2;Лист3!$A$2:$B$2839;2)

а это уже другой результат!
И крики "ВПР работает неправильно!"
 
Ну, наверное, точку с запятой нужно оставить последнюю, а за ней пусто
 
Если формулу ставить мастером (а я например впр почти всегда пишу так), и в последнее поле не ставить ничего - то как раз так вот криво и получается! По умолчанию там почему-то сделано криво...
И проще вбить в мастере туда 0, чем потом в строке формул выцеливать куда поставить ;
Изменено: Hugo - 28 окт 2020 00:30:31
Страницы: 1
Читают тему (гостей: 1)
Наверх