Страницы: 1
RSS
Разные форматы дат для граничных дней месяца и для других дней
 
Здравствуйте
Я написала пример в экселе в ячейке D3. В ячейке D2 похожая формула.
как написать  формулу: в последнем дне месяца и первом дне месяца, написать  месяц ,дату, запятая, год , а в других днях месяца писать только месяц и дату?
Спасибо!
Изменено: Mst Touch - 01.01.2021 09:37:30
 
=ЕСЛИ(ИЛИ(ДЕНЬ(A8)=1;ДЕНЬ(КОНМЕСЯЦА(A8;0))=ДЕНЬ(A8));ТЕКСТ(A8;"[$-409]ДДДД, ММММ Д, ГГГГ");ТЕКСТ(A8;"[$-9]МММ Д"))
Изменено: Михаил Витальевич С. - 24.12.2020 16:31:28
 
Михаил Витальевич С.,
Думаю, А2 и А5 тоже стоит заменить на А8, а не то второе и третье Января будут отображаться как декабрьские дни.
 
Михаил Витальевич С., условие можно такое:
ИЛИ(МЕСЯЦ(A8+{1;-1})<>МЕСЯЦ(A8))
 
 Спасибо. Я, наверно, не так написала
Я имела в виду преобразовать одну дату из ячейки A3., то есть 31.12.2020 превратить в "DEC 31, 2020".
Cледующую дату 01.01.2021 превратить  в "JAN 01, 2021"
Cледующую дату 02.01.2021 превратить  в "JAN 02"
то есть одна дата - одна формула

memo, получается Jan 2 , не получается DEC 31. 2020
 
vikttur,
я имела в виду на один день (A3)одну формулу, а здесь A8 и A3...
 
?
Проблема заменить ссылку в формуле?
 
УРА! ПОЛУЧИЛОСЬ! СПАСИБО БОЛЬШОЕ!
 
memo, Да, вы правы. Издержки копи-паста (проще говоря - лени :) )
 
Здравствуйте СНОВА!
Я разместила пример формулы в столбце Е, она выходит из формул в столбцах С и D. Хотелось бы одну компактную формулу чтобы сократить количество столбцов
Для граничных дней месяца формат даты "ММ ГГГГ-MM ГГГГ", для других дней - "ММ ГГГГ"

СПАСИБО БОЛЬШОЕ!!!
Изменено: Mst Touch - 01.01.2021 09:38:30
 
=UPPER(TEXT(A1;"[$-9]МММ ГГГГ") & IF(EOMONTH(A1;0)=A1;TEXT(A1;"[$-9]\-МММ ГГГГ");""))
Изменено: БМВ - 01.01.2021 10:09:24
По вопросам из тем форума, личку не читаю.
 
подставила, пишет ИМЯ?
 
У ведмедя Excel на аглицком.
Найдите транслятор формул, и переведите их  в русскую локаль.
 
Я перевела,спасибо, к сожалению, формула написана не так , как мне надо.
Я загрузила файл
В колонках А и B даты, в колонке С нужная формула - Она написана на дату последнего дня месяца (31е число)
А мне надо так,чтобы высвечивался МММ ГГГГ-МММ ГГГГ не зависимо от того, какая дата месяца (это может быть любая дата, не обязательно последнее число месяца).
Второе условие формулы работает верно  (то есть высвечивается МММ ГГГГ если обе даты принадлежат одному месяцу).
БОЛЬШОЕ СПАСИБО!
Изменено: Mst Touch - 03.01.2021 13:18:07
 
тогда так
По вопросам из тем форума, личку не читаю.
 
Работает,СПАСИБО!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх