Страницы: 1
RSS
Перемножение массивов с условием
 
Добрый день,

в примере выполняется перемножения массивов и их складывание по формуле:
Код
=СУММПРОИЗВ(A$1:A$33;B$1:B$33)+СУММПРОИЗВ(A$1:A$33;C$1:C$33)

В столбце D есть значения с ошибками, как перемножить и сложить значения исключая значения напротив столбца D. Спасибо.

Изменено: Александр Шиллер - 30.12.2020 12:37:21
 
обратите внимание на обработку ошибок с помощью функции ЕСЛИОШИБКА(...;0)
 
IKor,обращал))
Не пойму как воплотить в жизнь
 
в столбце Д есть ячейки с ошибками
а где в формуле хоть одна ссылка на эти ячейки, написанной в сообщении 1 формуле по барабану, что там в колонке Д
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Ігор Гончаренко, в том то и дело, что я не знаю как сделать то что я делаю, но с поправкой на ошибки в столбце D
 
а вам нужны ошибки в столбце Д?
если нет избавьтесь от них на стадии появления
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Александр Шиллер, если нужно умножить на D1:D33, исключая строки с ошибками:
=СУММПРОИЗВ(A1:A33;B1:B33+C1:C33;ЕСЛИОШИБКА(D1:D33;0))
если просто исключить строки, где в D1:D33 ошибки то:
=СУММПРОИЗВ(A1:A33;B1:B33+C1:C33;ЕСЛИ(ЕОШИБКА(D1:D33);0;1))
обе формулы массива
Страницы: 1
Читают тему (гостей: 1)
Наверх