Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Поиск значения на основе соответствия одного столбца нескольким
 
Что имеем:
На 1-м листе есть столбец ФИО, на 2-м листе есть 3 столбца Фамилия, Имя Отчество и еще зарплата. На 3-м листе нужно создать столбец ФИО с соответствующими зарплатами.
В чем проблема:
Фамилии имена и отчества иногда повторяются, при использовании простого ВПР Excel подставляем разным людям зарплату последнего человека с искомой фамилией, пробовал поставить условие (СУММЕСЛИ) соответствия ФИО=Ф&" "&И&" "&О, но не получилось.

Буду благодарен за помощь :)
 
Цитата
Вадим Комаровский написал:
На 1-м листе есть столбец ФИО, на 2-м листе есть 3 столбца Фамилия,
Вадим Комаровский, открываю файл эксель; в нем всего один лист, и тот пустой...
 
Цитата
Михаил Витальевич С. написал:
открываю файл эксель
намек понят, ссылка на файл: https://drive.google.com/file/d/13puDyt-VpOr_kj2rbEtHCf5GcVflmcwS/view?usp=sharing
(если ссылки на данном форуме не в почете и был какой-то способ вставить файл, то прошу прощение)
 
Как вариант можно из результата массивной
Код
=ВПР(A2;Лист2!$A$2:$A$10&" "&Лист2!$B$2:$B$10&" "&Лист2!$C$2:$D$10;2;0)

вырезать последнее слово. Скрин: http://prntscr.com/we7d5f
Но проще ведь сделать столбец, по которому можно спокойно вприть или индекспозицить :)
Изменено: Hugo - 1 янв 2021 19:18:36
 
Вадим Комаровский, Так у вас файл Googl-Tabs, или Excel?
Если гугл - то нужно дать доступ на редактирование, и ссылку на сам файл; если Excel, внизу ответа ссылка - "Загрузить файлы"
 
Ах, Excel, не заметил кнопку)
 
Цитата
Hugo написал:
Но проще ведь сделать столбец, по которому можно спокойно вприть или индекспозицить
По скрину вроде задача выполнена, но уродец получается. Над созданием еще одного столбца думал, но так получаются костыли, хочется качественно все сделать.
 
В файле два варианта: с дополнительным столбцом и обычный ВПР, и формула массива без доп. столбца.
 
Благодарю, мало что понимаю во второй формуле, но она идеальна!
Страницы: 1
Читают тему (гостей: 1)
Наверх