Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Массовый подбор значений с помощью VBA
 
Здравствуйте!

Нужен подбор значения в автоматическом режиме.
Нашёл здесь макрос для одной ячейки. Нужно посчитать весь столбик.
Код
Sub T1()
    X = Range("A10")
    Range("B10").GoalSeek Goal:=X, ChangingCell:=Range("A10")
End Sub
Ячейка B10:
Код
=ЕСЛИ(J10="Продается";(A10-O10-C10)-R10*(L10/100);"не продается")

Работает так:
В ячейку B10 я ввожу своё значение, к которому стремлюсь. А в ячейке A10 появляется значение которое для этого нужно.
 
Инструмент называется Подбор параметра. Пробежаться по строкам  - циклом (в примере - со 2 по 100 строку)
Код
Sub T2()
    Dim X As Double
    Dim i As Long

    For  i = 2 To 100
         X = Cells(i, 1).Value
         Cells(i, 2).GoalSeek Goal:=X, ChangingCell:=Cells(i, 1)
    Next i
End Sub
 
Прошу прощения.
Переоценил свои возможности, надеялся, что сходу разберусь )
 
Писал же:
Цитата
циклом (в примере - со 2 по 100 строку)
Вы вставили, как есть, а надо же смотреть по своим данным:   For i = 2 To 12 -  со  2 по 12 строки.

Цитата
propulsion написал: В ячейку B10 я ввожу своё значение,
Значение должно быть числовым, а "не продается" - это текст. Добавил условие - если не продается, то в столбец А пишем ноль
Код
Sub T2()
    Dim X As Double
    Dim i As Long
  
    For i = 2 To 12
        If Cells(i, 7).Value = "Продается" Then
            X = Cells(i, 1).Value
            Cells(i, 2).GoalSeek Goal:=X, ChangingCell:=Cells(i, 1)
        Else
            Cells(i, 1).Value = 0
        End If
    Next i
End Sub
 
Работает!
vikttur, спасибо Вам огромное!
Страницы: 1
Читают тему (гостей: 1)
Наверх