Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Контроль заполнения расчета по единой модели, при наличии сторонних моделей или записей отобразить рекомендацию
 
Добрый день, помогите создать формулу:

Допустим есть таблица в которой в столбце "Модель" (выделен зелёным) с 2 по 16 строку нужно выбрать модель оборудование из выпадающего списка. А в строке с 17 по 31-ю вводится любой другой товар (не из выпадающего списка)

Нужно чтобы в определенной ячейке (выделена розовым)при выборе в массиве ячеек С2:С16 из выпадающего списка модели не содержащего в названии слова "Бирюса", или введении в массиве ячеек С17:С31 в любую ячейку текста который не содержит "Бирюса" появлялось текстовое выражение.
А если в массиве С2:С31 введены только слова содержащие слово "Бирюса" или ячейки пустые, то текстовое выражение не появлялось.

У меня получилось задать формулу, проверяющую содержание одной ячейки, а вот для массива не получается ))) Замучилась.
Код
=ЕСЛИ(ИЛИ(ЕЧИСЛО(ПОИСК("Бирюса";С2));С2=0);"";"Заказать сопутствующие"

 
Добрый и Вам. Пример бы глянуть. Что есть, что хотите получить.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Функция применяется во многих задачах. Предложите название темы, отражающее конкретную задачу. Заменят модераторы
 
Цитата
vikttur написал:
Предложите название темы, отражающее конкретную задачу
Помогите пожалуйста предложить )
 
Кто лучше Вас знает проблему?
 
Цитата
vikttur написал:
Кто лучше Вас знает проблему?
Так я её подробно описала в самом вопросе.
Помогите пожалуйста мне ее корректно назвать.
 
vikttur, тема: "Контроль заполнения расчета по единой модели и при наличии сторонних моделей или записей отобразить рекомендацию ЗАКАЗАТЬ  СОПУТСТВУЮЩИЕ"
Код
=ЕСЛИ(СЧЁТЕСЛИ(Модель;ЛЕВСИМВ(C2;ПОИСК(" ";C2)-1)&"*")=СУММПРОИЗВ(--НЕ(ЕПУСТО(Модель)));"";"ЗАКАЗАТЬ  СОПУТСТВУЮЩИЕ")
Лень двигатель прогресса, доказано!!!
 
Сергей, огромное вам спасибо.
Вы похожи на волшебника  :) , доброго.
Не могли бы вы в двух словах объяснить каким образом ячейка понимает, что в диапазоне нет слова "Бирюса"?
И в двух словах, если есть время, про то как работает основная часть формулы:
Код
СЧЁТЕСЛИ(Модель;ЛЕВСИМВ(C2;ПОИСК(" ";C2)-1)&"*")=СУММПРОИЗВ(--НЕ(ЕПУСТО(Модель)))
 
Цитата
Оксиген Ёлкина написал:
каким образом ячейка понимает, что в диапазоне нет слова "Бирюса"
не совсем понятно что хотите, но формула работает по принципу берет с первой записи Модель холодильника и считает сколько записей с такой моделью есть в диапазоне, вторая часть формулы считает сколько строк заполнено потом эти два числа сопоставляются и в случае не совпадения выдается сообщение
Лень двигатель прогресса, доказано!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх