Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Сумма определённых столбцов по условиям
 
Здравствуйте!

Помогите, пожалуйста, с формулой для случая, когда нужно в строке суммировать значения только из столбцов, которые определены для каждого названия строки в другой таблице.
Упрощенный пример моего случая прикладываю. Вид таблицы 1 для удобства можно как-то изменить, а таблица 2 должна быть в таком же виде.
Похожие темы не нашла.

Спасибо!
Изменено: elengonch - 26 янв 2021 20:00:18
 
Добрый день! Вы файл с примером не прикрепили
 
Пример добавила.
Изменено: elengonch - 26 янв 2021 20:02:11
 
Что ж в итоге нужно получить?
По вопросам из тем форума, личку не читаю.
 
вариант
Код
=СУММ(ЕСЛИОШИБКА(ПОИСКПОЗ(F3&$G$2:$K$2;$B$3:$B$11&$C$3:$C$11;)^0;0)*G3:K3)
Код
=СУММ(ЕЧИСЛО(ПОИСКПОЗ(F3&$G$2:$K$2;$B$3:$B$11&$C$3:$C$11;))*G3:K3)

Цитата
БМВ написал:
Что ж в итоге нужно получить?
дык суммы, без яблок и бананов - как написано  ;)
Изменено: buchlotnik - 26 янв 2021 20:11:28
Каждому For свой Next
 
=SUMPRODUCT(G3:K3*(G$2:K$2=$C$3:$C$11)*($B$3:$B$11=$F3)) ну да, круть :-)
Еще массивный прикол
=SUM(SUMIFS(G3:K3;G$2:K$2;IF(B$3:B$11=F3;C$3:C$11)))
Изменено: БМВ - 26 янв 2021 20:20:17
По вопросам из тем форума, личку не читаю.
 
buchlotnik, БМВ, Спасибо вам огромное за помощь!

Взяла в свою работу формулу БМВ
buchlotnik, Ваши формулы не работают у меня, наверно из-за версии excel 2019
 
Цитата
elengonch написал:
А эти формулы не работают
они просто требуют массивного ввода как и моя вторая.
По вопросам из тем форума, личку не читаю.
 
БМВ, понятно, всё сработало теперь. Спасибо еще раз, очень помогли!
Страницы: 1
Читают тему (гостей: 1)
Наверх