Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Dax Нарастающая сумма, Power Bi и Power Pivot
 
Здравствуйте!
Как получить в Power Pivot и Power Bi нарастающую сумму?
Наверняка уже такие темы были, но не нашел.
 
Доброго дня, Михаил, тут показывал варианты как для столбца так и для меры.
Вот горшок пустой, он предмет простой...
 
PooHkrd, я так понял что там меры по ссылке работают с отсортированными данными. И у меня в примере совпало сортировка от мин к макс. А вообще данные не сортированы.
Пример изменил. Возможно ли так? Мерой
ps. аналог формулы -  =СУММ(H$5:H6)
Изменено: Михаил Л - 18 фев 2021 09:46:10
 
Для нарастающей суммы в DAX обязательно должен быть столбец, который задает порядок обхода строк, в вашем случае, это либо значение суммы, либо по алфавиту по Столбцу1. Лично я других способов не знаю. Да и случаев таких в работе не припомню, когда такое потребовалось бы. Чаще всего нарастающий считаю по датам, либо индексам, которые сочиняю в PQ и гружу в модель для всяких извращенских расчетов.
Вот горшок пустой, он предмет простой...
 
Цитата
PooHkrd написал:
нарастающий считаю по датам, либо индексам
Честно не знал. Думал считают по принципу как List.Generate в PQ.
По датам наверное возможно?
По новому примеру возможно ли в рамках города считать по месяцу и просто дате? А если по городу, то сверху вниз общие суммы по городам.  
 
у меня вот такой вариант получился:
Код
=IF(
   [summa]=BLANK();
   BLANK();
   IF(
      HASONEVALUE('Календарь'[Date]);   
      CALCULATE([summa];DATESMTD('Календарь'[Date]));
      CALCULATE([summa];DATESYTD('Календарь'[Date]))
   )
)

Обязательно нужно создать измерение "календарь" с непрерывными датами - для работы функций рода: DATESYTD.
 
Vladimir Chebykin, большое спасибо!
В примере еще по городам нарастающе суммировалось, но это уже лишнее.
Страницы: 1
Читают тему (гостей: 1)
Наверх