Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Формула суммы чисел в текстовой строке
 
Доброго времени суток. Прошу помощи.
Необходимо суммировать числа в строке где числа разделены запятой.

Пример:
было: 1,21,75,100,3fxuvvcxxcjcvvvffbccg
требуется: 200

Не цифр, а чисел.

Заранее спасибо!
 
Массивная
=SUM(IFERROR(--MID(SUBSTITUTE(","&LEFT(A1;MAX((MID(A1;ROW(1:99);1)=""&TRANSPOSE(ROW(1:10)-1))*ROW(1:99)));",";REPT(" ";LEN(A1)));ROW($1:$99)*LEN(A1);LEN(A1));))
Изменено: БМВ - 7 апр 2021 19:39:19
По вопросам из тем форума, личку не читаю.
 
Формула массива, ввод тремя клавишами:
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(","&ЛЕВБ(A2;ПОИСКПОЗ(1=1;КОДСИМВ(ПСТР(A2;СТРОКА($1:$99);1))>57;)-1);
",";ПОВТОР(" ";99));СТРОКА($1:$9)*99;99);))
 
Вить а если попадется всякая дрянь что меньше 48?
думаю так
ABS(КОДСИМВ(ПСТР(A2;СТРОКА($1:$99);1))-52,5)<=4,5
По вопросам из тем форума, личку не читаю.
 
Цитата
Необходимо суммировать числа в строке
UDF
Код
Function iSumma(cell As String) As Double
Dim arr
Dim i As Integer
  arr = Split(cell, ",")
  For i = 0 To UBound(arr)
    iSumma = iSumma + Val(arr(i))
  Next
End Function
 
до кучи
Код
=СУММ(ФИЛЬТР.XML("<b><i>"&ПОДСТАВИТЬ(ЛЕВБ(A2;ПОИСКПОЗ(1=1;КОДСИМВ(ПСТР(A2;СТРОКА($1:$99);1))>57;)-1);",";"</i><i>")&"</i></b>";"//i"))
Каждому For свой Next
 
Друзья! Спасибо всем большое.  
Страницы: 1
Читают тему (гостей: 1)
Наверх