Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Вычисление среднего числа промежуточных отрезков времени между точками роста запаса
 
Приветствую коллеги!Не раз получал здесь здравую помощь) Помогите решить задачку, как мне вычислить среднюю цифру  по кол-ву дней, когда запас не пополняется (белые ячейки между красными). Т.е например Гайка 6 дней не пополняется, далее 07.01 пополнение, затем 22 дня не пополняется, опять 30.01 пополнение  и вот таким образом получается за весь период позиция идет с промежутками без пополнения 6,22,5,8,12,6,5,6,6,8 в среднем 8,4. Вот как эту цифру через формулу вычислять?

Пример во вложении )
 
непонятно вам нужно сделать для конкретного периода или среднюю за все периоды
Лень двигатель прогресса, доказано!!!
 
за период который указан в примере 01.01.2021 - 05.04.2021 ))
 
с начало не понял что считаем
Код
=СУММПРОИЗВ(--(C3:CS3<=B3:CR3))/СУММПРОИЗВ(--(C3:CS3>B3:CR3))
Изменено: Сергей - 8 апр 2021 09:26:35
Лень двигатель прогресса, доказано!!!
 
Код
=(ИНДЕКС($2:$2;МАКС(ЕСЛИ(E3:CT3>D3:CS3;СТОЛБЕЦ(E3:CT3))))-$D$2+1)/(СУММ(--(E3:CT3>D3:CS3)))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
да почти то что нужно , такой же тип расчетов, только,чтобы вместо суммы средней была средняя по количеству значений, возможно такое? ))
 
загрузил файл в сообщении выше то не то
Лень двигатель прогресса, доказано!!!
 
Вот в примере позиция рейка, идут последовательно промежутки не пополняемые 17 дней, 10, 9, 30,25  получается в  среднем 18,2 дня, а формула дает результат 22,75  ?? что не хватает))
 
+1 не хватает формула считает пики пополнения а их 4
Код
=СУММПРОИЗВ(--(C3:CS3<=B3:CR3))/(СУММПРОИЗВ(--(C3:CS3>B3:CR3))+1)
Лень двигатель прогресса, доказано!!!
 
Благодарю! Результат отличный! Тему можно закрывать)
Страницы: 1
Читают тему (гостей: 4)
Наверх