Страницы: 1
RSS
Подсчет количества символа на определенном месте в разных ячейках
 
Камрады!

Есть набор ячеек со стрингами
AB
1aBCFDrvdasAssssAAA
2aaaacBcBBBfd
3dfcBBBBajBBBabb
4aBeeBebBbbbB
Нужно подсчитать количество сомвола "B" который втсречается во всех ячейках на 2 месте
На примере выше, таковых -  5

Пытался делать в этом направлении:
=SUMPRODUCT(LEN(A1:B4) - LEN(SUBSTITUTE(SUBSTITUTE((A1:B4), "B", ""), "B","")))
но данная формула считает все символы "B", как, впрочем и такая конструкция:
=COUNTIF(A1:B4,"*B*")
В первом случае , получаю 17, во втором 6
 
Файл бы увидеть.
Без файла так:
=СУММПРОИЗВ(--(ПСТР(A1:B4;2;1)="B"))
Изменено: Максим В. - 29.04.2021 16:53:54
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Цитата
Максим В. написал:
=СУММПРОИЗВ(--(ПСТР(A1:B4;2;1)="B"))
бинарное отрицание - слишком мудренно
Страницы: 1
Читают тему (гостей: 1)
Наверх