Страницы: 1
RSS
[ Закрыто ] Поиск текста в ячейке и вывод в отдельную ячейку при идентичности в 2 массивах данных
 
Добрый день, нужен ваш совет и ваша помощь.
Выполняю дипломную работу по управлению домашними финансами.
вопрос 1: Имеется массив данных, нужно вывести MCC код в отдельную ячейку
Я обратил внимание, что MCC код находится в самом конце, в следствии чего выполнил формулу в [столбце K]:
=ЕСЛИ(J36=1;ПРАВСИМВ(F36;7);"")
какая будет формула, если MCC код будет случайным образом расположен среди текста? (столбец F), спасибо.

вопрос 2:имеются 2 массива данных (1 массив представлен на 1 картинке выше, 2 массив данных на 2 картинке ниже)
Нужно MCC код из [массив 1 или вопрос 1] подставить напротив каждой транзакции в столбце K на 2 массиве. Имеются 2 повторяющихся элемента в ячейке = [Дата] и [Сумма].
Если сформулировать иначе: вывести в столбец К второго массива МСС код при выполнении сравнения и совпадения [Дата] и [Сумма] по 2 массивам данных.

вопрос 3:
как упростить формулу? чтобы определить статью затрат в рамках MCC кода, я применил формулу в [столбце М]
=ПРАВСИМВ(G25;ДЛСТР(G25)-НАЙТИ("\";G25)) чтобы вывести значение после "\"
далее посторил данную формулу, чтобы вывести значение после второй "\"
=ПРАВСИМВ(M25;ДЛСТР(M25)-НАЙТИ("\";M25))
уверен, что можно обойтись 1 формулой, но пока не справился с данной задачей, спасибо.

Заранее спасибо,
если поможете с ответом, то можно просто 1 - ответ, 2 - ответ, 3 - ответ, спасибо.

С Уважением Алексей
 
Алексей Гусев, если " нужен... совет и... помощь", то для начала нужно ознакомиться с правилами форума, не лепить в одну тему несколько вопросов, показать пример в файле Excel
Страницы: 1
Читают тему (гостей: 1)
Наверх