Страницы: 1
RSS
Как применить интервальный поиск для расчета KPI
 
Добрый вечер!

Господа знатоки, нужно считать выполнение плана менеджером. 4 коридора:
1. <80%
2. >=80%-100%
3. >=100% - <120%
4. >= 120%

В зависимости от выполнения плана подтягивается коэффициент премирования.
Прописал формулой Если с нескольким аргументами. Но отрабатывает коряво.

Прошу Вас указать на ошибку и поправить код)  
Изменено: vikttur - 10.06.2021 23:12:26
 
Модераторам предлагаю название темы
Как применить интервальный поиск для расчета KPI
Вот формула
Код
=ВПР(E6;{0;0:0,8;0,3:1;0,5:1,2;0,7};2;1)
Вот горшок пустой, он предмет простой...
 
Добрый

Не умеет excel так
Цитата
E6>=100%<120%
Если очень хочется через ЕСЛИ, то условия записывайте через И
Код
И(E6>=100%;E6<120%)
, другие варианты не подходят под Ваше название темы
Изменено: bigorq - 10.06.2021 20:02:12
 
Код
=ЕСЛИ(E6<80%;0;ЕСЛИ(И(E6>=80%;E6<100%);B6;ЕСЛИ(И(E6>=100%;E6<120%);C6;ЕСЛИ(E6>=120%;D6))))
 
Adrey Stalnoy,
рекомендую отойти от ваших железных принципов работы с ЕСЛИ и обратить внимание на наличие других функций листа Еxcel  
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
И чего набросились на человека? И вложенность то небольшая, вполне и ЕСЛИ справится
=ЕСЛИ(E6>=1,2;0,7;ЕСЛИ(E6>=1;0,5;ЕСЛИ(E6>=0,8;0,3;0)))
 
Цитата
RAN написал:
И чего набросились на человека?
я файл не смотрел и не набрасывался. я написал рекомендацию, которую, кстати, можно закинуть за дальние горы
или еще лучше полностью проигнорировать и даже не заниматься закидыванием - это более оптимальное отношение к написанному мною (и не только в этой теме)))
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Цитата
RAN написал:
И вложенность то небольшая,
но инверсировать короче.
=ЕСЛИ(E6<0,8;;ЕСЛИ(E6<1;0,3);ЕСЛИ(E6<1,2;0,5;0,7)))
=ЕСЛИ(E6<0,8;;ЕСЛИ(E6<1;3);ЕСЛИ(E6<1,2;5;7)))/10
По вопросам из тем форума, личку не читаю.
 
И еще вариант:
Код
=МАКС(3;МИН(7;ОКРВНИЗ(E6*10-8;2)+3))/10
Изменено: PooHkrd - 11.06.2021 08:37:41
Вот горшок пустой, он предмет простой...
 
Всем спасибо за советы.
Привычнее всегда использовать то, к чему привык ранее. Но замечания учту.  
Страницы: 1
Читают тему (гостей: 1)
Наверх