Страницы: 1
RSS
Разный множитель в зависимости от значения ячейки и умножение на процент в зависимости от значения ячейки
 
Добрый день!

Есть задачи в таблице производить следующие расчеты:

В случае, если в столбце C-R значение больше или равно 10 производить следующие арифметические действия:

1. Берется значение из столбца B делится на 31 и такое действие нужно производить с каждой ячейкой диапазоне с C2 по R2 в конце результаты делений складываются.

Также есть два дополнительные условия: если значение ячейки в диапазоне с  C2 по R2 меньше или равно три, то после деления на 31 нужно добавить +50%; если значение ячейки  C2 по R2 4 или 50 нужно добавить после деления к результату + 20%.

Таблицу прилагаю. Интересует реально ли это сделать в эксель или начать изучать пайтон для реализации задачи. Спасибо заранее за ответ.Лист Microsoft Excel.xlsx (10.27 КБ) Лист Microsoft Excel.xlsx (10.27 КБ)  
 
Цитата
Денис Жуков написал:
Интересует реально ли это сделать в эксель
да.

Покажите желаемый результат расчет в уме сделайте или на калькуляторе для 5-10 строк, а так наугад без доп условий =ЕСЛИ(СЧЁТЕСЛИ($C2:$R2;">="&10)>=1;$B2/31+СУММ($C2:$R2)/31)
Изменено: Mershik - 20.06.2021 21:59:50
Не бойтесь совершенства. Вам его не достичь.
 
Добрый день!
Мне кажется, что здесь функция СЧЁТЕСЛИ не очень подходит. Полагаю, что нужно считать отдельно по каждой ячейке результат и в конце суммировать результаты по каждой ячейке.
Изменено: vikttur - 26.06.2021 00:26:13
 
Цитата
Mershik написал:
Покажите желаемый результат
это означает показать в файле
Не бойтесь совершенства. Вам его не достичь.
 
Цитата
Денис Жуков написал:
В случае, если в столбце C-R значение больше или равно 10 производить следующие арифметические действия:
т.е. начинаем деление столбца В на 31 только после выполнения этого условия

тогда не понятны дальнейшие действия
Цитата
Денис Жуков написал:
Также есть два дополнительные условия: если значение ячейки в диапазоне с  C2 по R2 меньше или равно три, то после деления на 31 нужно добавить +50%; если значение ячейки  C2 по R2 4 или 50 нужно добавить после деления к результату + 20%.
если значения в строке C2 по R2 <=3 или =4 они априори меньше 10 соответственно они первое условие не выполнено и ни чего делить не надо
Лень двигатель прогресса, доказано!!!
 
совершенно верно арифмитические действия со значением ячейки нужно производить только, если значение ячейки больше или равно 10. В противном случае ячейку нужно пропускать, не производя с ней никаких действий.
Суммировать нужно результаты по ячейкам, в которых производились расчеты.

Прикрепил файл с расчетами.
Изменено: vikttur - 26.06.2021 00:26:46
 
Денис Жуков,
Загуглите (очевидно, вы не знаете) значение слова ЦИТАТА, а потом сравните со своим «шедевром»
Изменено: Jack Famous - 21.06.2021 10:33:08
Во всех делах очень полезно периодически ставить знак вопроса к тому, что вы с давних пор считали не требующим доказательств (Бертран Рассел) ►Благодарности сюда◄
 
Код
=СУММ(ЕСЛИОШИБКА(B2/31*C2:G2;0)*(C2:G2<=10)*(C2:G2>5);(C2:G2<10)*(C2:G2>=4)*ЕСЛИОШИБКА(1.2*B2/31*C2:G2;0);(C2:G2=3)*ЕСЛИОШИБКА(1.5*B2/31*C2:G2;0))
Изменено: Тимофеев - 21.06.2021 12:19:43
 
Денис Жуков, ещё одна цитата в Вашем исполнении - и я закрою тему.
Страницы: 1
Читают тему (гостей: 1)
Наверх