Страницы: 1
RSS
Макрос на считывание и повторение значения с выделенной ячейки до нового значения и далее циклично, Цикличный Макрос
 
Приветствую!
Прошу показать какой макрос нужен для выполнения приведённого примера ниже!

В ячейках  листа в одной колонке введено большое количество данные в разных интервалах удалённости.
Необходимо повторить значение выделенной первой ячейки по столбцу в низ до нового значения, после считать новое значение и повторить до следующего, ограничив общее количество повторений или повторений нового значения

Самостоятельно пытался сделать, но я так и не понял как.
Файл как пример для теста

Или ссылку на похожую задачу, мне главное понять как повторить значение до нового и продолжить, при этом не вернутся в начало =D
Изменено: vikttur - 18.09.2021 21:48:46
 
Добрый вечер. Ссылка
 
в В3
Код
=ЕСЛИ(ЕПУСТО(A3);B2;A3)
и тянете В3 вниз сколько есть сил
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
Счёёёё Сумм, активируете ячейку А4 -- нажимаете CTRL+SHIFT+END --  нажимаете  F5 -- выделить -- пустые ячейки -- ок --в строке формул сделать вручную написать =A3 -- нажать CTRL+ENTER
если конечно нужен макрос:
Код
Sub meshkei()
Dim arr, i As Long, lr As Long, fr As Long
lr = Cells(Rows.Count, 1).End(xlUp).Row
If Range("A1") = Empty Then
    fr = Range("A1").End(xlDown).Row
Else
    fr = 1
End If

arr = Range("A" & fr & ":A" & lr)
For i = LBound(arr) To UBound(arr)
    If arr(i, 1) = Empty Then
        arr(i, 1) = arr(i - 1, 1)
    End If
Next i
Range("A" & fr).Resize(UBound(arr), 1) = arr
End Sub
Изменено: Mershik - 18.09.2021 20:58:29
Не бойтесь совершенства. Вам его не достичь.
Страницы: 1
Читают тему (гостей: 1)
Наверх