Страницы: 1
RSS
пользовательский формат ячейки
 
прошу помочь с пользовательским форматом ячейки

в общем вытягиваю с помощью вот этой формулы
Код
=ЕСЛИОШИБКА(ИНДЕКС('Перечень ИД'!$Q$4:$Q$5003;ПОИСКПОЗ(ОВ!B2;'Перечень ИД'!$D$4:$D$5003;0));"")

данные в другую таблицу
в ячейках в которых я вытягиваю находятся данные в текстовом формате и в формате даты
проблема в том, что вытягивая с помощью формулы (см.выше) текст определяется как текст, а вот дата отображается некорректно и отображается как число,
а мне нужно что бы текст вытягивался как текст, дата как дата + если в ячейке 0 то он ее скрывал как будто ячейка пустая

помогите пожалуйста
Изменено: vikttur - 14.10.2021 10:57:32
 
Цитата
T Kur написал: находятся данные в текстовом формате и в формате даты
Если только такие данные, можно присвоить ячейке с формулами формат: "ДД.ММ.ГГГГ;-#;"
 
блин спасибо большое)
я еще в формуле поправил что бы не отображалось в фильтре эти нули, вот так
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС('Перечень ИД'!$Q$4:$Q$5003;
      ПОИСКПОЗ(ОВ!B2;'Перечень ИД'!$D$4:$D$5003;0));"")=0;"";
      ЕСЛИОШИБКА(ИНДЕКС('Перечень ИД'!$Q$4:$Q$5003;
      ПОИСКПОЗ(ОВ!B2;'Перечень ИД'!$D$4:$D$5003;0));""))
Изменено: vikttur - 14.10.2021 10:57:04
 
Уточните название темы. Сейчас общее. Заменят модераторы
Страницы: 1
Читают тему (гостей: 1)
Наверх