Страницы: 1
RSS
Округление с учетом нолей, Округление с учетом нолей
 
В ячеке D1 есть число: 0.0015, необходимо округлять значения в ячеках A1;B1;C1 до количества знаков после запятой в ячейке D1 c учетом нулей. Число которое будет в ячеке D1 может иметь разное количество знаков после запятой. В примере указано, что дано и какойдолжен бытьрезультат. Спасибо.
 
1) Макрос:
Код
Sub fgfgfg()
x = Len(Split(Range("D1").Text, ",")(1))
Range("A2:C2").NumberFormat = "0." & WorksheetFunction.Rept(0, x)
x = Len(Split(Range("D4").Text, ",")(1))
Range("A5:C5").NumberFormat = "0." & WorksheetFunction.Rept(0, x)
End Sub
2) Можно и формулой, если  формат нужной ячейки в столбце D будет "Общий".
Только возвращаемый результат формулой будет текстом а не числом (см. файл).
Изменено: Бахтиёр - 14.10.2021 09:13:09
 
Да макросом предпочтительнее решение, этот вариант прекрасно работает. Не могли бы Вы помочь переделать этот макрос для округления значений в столбцах от A до С, относительно значений в столбце D для каждой строки? И как можно сделать, что б макрос разбалтывал при любом изменении на листе? Спасибо!
 
Ещё вариант. Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ТЕКСТ(A1;"0,"&ПОВТОР(0;МАКС(ОТБР(2-LOG(Ч(+$A1:$D1))))))
Если ориентироваться только по столбцу D, то формула проще:
Код
=ТЕКСТ(A1;"0,"&ПОВТОР(0;ОТБР(2-LOG($D1))))
Результаты в виде текста.
Изменено: Светлый - 15.10.2021 09:50:35
Страницы: 1
Читают тему (гостей: 1)
Наверх