Страницы: 1
RSS
Произведение ячеек только содержащих цифровые значения, перемножение только цифровых ячеек
 
Добрый день!

Есть несколько ячеек (в строке), которые нужно перемножить, но:
если ячейка пустая - она принимается как =1 в общем перемножении.
 
И где оно?
 
Прошу извинить, не прикрепил..
 
если "в лоб"
Код
=ЕСЛИ(A3=0;1;A3)*ЕСЛИ(B3=0;1;B3)*ЕСЛИ(C3=0;1;C3)*ЕСЛИ(D3=0;1;D3)*ЕСЛИ(E3=0;1;E3)*ЕСЛИ(F3=0;1;F3)
 
Спасибо большое !!!
 
Думаю скоро придут формулисты и напишут более короткую формулу
 
Код
=ПРОИЗВЕД(ЕСЛИ(A3:G3=0;1;A3:G3))
формула массива
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
=ПРОИЗВЕД(ЕСЛИОШИБКА(--(A3:F3&"");1))
Формула массива, ввод тремя клавишами
 
=PRODUCT(A3:F3)
оно само пропускает пустую ячейку и нечего огород городить.
По вопросам из тем форума, личку не читаю.
 
Цитата
БМВ написал:
=PRODUCT(A3:F3)
Нет вроде бы такой функции в екселе....
 
В русском екселе нету. Там она называется ПРОИЗВЕД
Изменено: vikttur - 18.10.2021 08:30:55
 
Цитата
БМВ написал:
оно само пропускает пустую ячейку и нечего огород городить
так там по сути не пустая получается, а 0. И тогда итоговым результатом тоже 0 будет. Я выше именно её и применил, но с условием - иначе никак.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Дмитрий, если там будет 0, то да, но если пусто, то проигнорирует функция. Собственно, как и любое нечисловое значение.
По вопросам из тем форума, личку не читаю.
 
Цитата
БМВ написал:
если там будет 0, то да
ну вот в примере он самый и есть :) Человек пишет:
Цитата
Илья Волкотруб написал:
если ячейка пустая - она принимается как =1
не текстовая строка нулевой длины, а именно полностью пустая. Которая в математическом смысле Excel-м воспринимается именно как 0.  
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Главное для ТС, что если ввести в ячейку G3 формулу
Код
=ПРОИЗВЕД(A3:F3)

то она даёт нужный результат 2965,44, как и хотел ТС, при этом в ячейке B3 - пусто. Видно ПРОИЗВЕД просто игнорирует пустые ячейки, а не подставляет в пустую ячейку 0 - иначе и результат был бы 0
Изменено: New - 18.10.2021 12:28:03
 
New, у меня так не срабатывает и возвращает 0. В том же файле ТС...
упс, не заметил, что без последней ячейки G3. Да, тогда я что-то попутал и функция действительно пропускает пустые ячейки :(  Не обратил внимания на то, что последняя ячейка у ТС изначально с нулем.
Да, без неё срабатывает. Однако, надо полагать, что нули все же могут быть.
Изменено: Дмитрий(The_Prist) Щербаков - 18.10.2021 12:36:23
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
если в ячейках будет 0, тогда пусть ТС возьмёт другую формулу из предложенных. Мы накидали ему вариантов, а выбирать ему )
А сейчас - какой пример в файле, такой и ответ )
Изменено: New - 18.10.2021 12:41:48
Страницы: 1
Читают тему (гостей: 1)
Наверх