Страницы: 1
RSS
Подсчёт кВт и двузонный тариф
 
Доброго времени суток.
Я ввожу данные счётчика каждый день.
Дата = столбец A
Время = столбец B
кВт = столбец C

Нужно подсчитывать автоматически разницу кВт с последнего по первое значение в ячейку D1 и стоимость в ячейку E1 при условии <250кВт = 144коп и >250кВт = 168коп.
 
Добрый день! Файл пример приложите с тем что есть и тем, что должно получиться
 
Ну вот есть такое
https://www.dropbox.com/s/nhub2babjdbutjw/%D0%A1%D0%B2%D0%B5%D1%82.xlsx?dl=0

А как должно быть для этого и обратился на форум :)
 
Цитата
написал:
автоматически разницу кВт с последнего по первое значение
разница киловат
Код
=(МАКС(C:C)-МИН(C:C))
сумма в гривнах
Код
=ЕСЛИ((МАКС(C:C)-МИН(C:C))<=250;(МАКС(C:C)-МИН(C:C))*1,44;250*1,44+((МАКС(C:C)-МИН(C:C))-250)*1,68)
можно свернуть раз киловаты в отдельной ячейке D1
Код
=ЕСЛИ(D1<=250;D1*1,44;250*1,44+(D1-250)*1,68)
Изменено: andylu - 25.11.2021 15:26:23
 
Ну вот, всё красиво. Большое БлагоДарю!

Цитата
написал: но при чем тут двухзонность, и зачем вам записывать время и даты, без файла примера ответа нет.
Зачем двузонность = Скрин
Так если я пример напишу, то значит задачу решил и тогда смысл топика пропадает :)
 
Цитата
написал:
Зачем двузонность =  Скрин
я же к этому и намекал = в первом сообщении темы нет поправочных коэффициентов на время суток никаких ;)
 
Кнопкой цитирования нужно пользоваться, когда цитата необходима, а не для бездумного копирования [МОДЕРАТОР]

Просто не так понял, что значит пример.
Хотя двузонность наверное не нужна (нужно уточнить).
Страницы: 1
Читают тему (гостей: 1)
Наверх