Страницы: 1
RSS
АВТОЗАПОЛНЕНИЕ ЯЧЕЕК В EXCEL ИЗ ДРУГОЙ ТАБЛИЦЫ ДАННЫХ С НАЛИЧЕЕМ ОПРЕДЕЛЁННОГО СЛОВА
 
Доброго времени суток всем.
Перейду сразу к делу. Есть таблица в которой я прописываю; адреса по которым я ездил, предоставленные услуги потребителям и время отведённое на выполнение заявки (по прописанному прайсу компании). Я уже сделал так, что бы таблица сама заполняла предоставленные услуги и их номер по базе, но проблема заключается в том, что время отведённое на работу, имеет разные значения для заявок в городе и за городом. У меня есть примерная формула
Цитата
=ИНДЕКС('Услуги и время'!$A$2:$F$44;ПОИСКПОЗ(F5;'Услуги и время'!$B$2:$B$44;0);ПОИСКПОЗ(H$3;'Услуги и время'!$A$1:$G$1;0))
Но она не будет учитывать коэффициенты, которые будут за городом. И мне нужно что бы формула могла понимать, что я сделал и где я её сделал и понимала какой коэффициент выставлять (если в графе Адрес есть слово "Усолье" или "Правый берег" то прописывал время загородом).
Ещё одна проблема заключается в том, что может быть несколько квартир по одному адресу и тогда нужно заполнить столбец с количеством квартир. И тут уже нужно что бы эта формула могла не просто "понимать, что я сделал и где я её сделал и понимала какой коэффициент выставлять", но и умножать на количество квартир.
В приложенном файле имеется страница с прописанным временем и услугами.
Я не знаю смогут ли мне помочь здешние энтузиасты  и мастера своего дела, но буду невероятно вам признателен за любую помощь.
Изменено: Савелий Казаков - 19.01.2022 01:41:59
 
Савелий Казаков,  у Вас Caps  заклинило?
 
Савелий Казаков, нажмите кнопку над столбцом время
Страницы: 1
Читают тему (гостей: 1)
Наверх