Страницы: 1
RSS
Сортировка и фильтрация диапазона данных формулой_(?)
 
Здравствуйте, уважаемые коллеги!
Прошу помощи в написании формулы позволяющей провести фильтрацию и сортировку диапазона данных.
1. Есть столбец (А) с текстом. Строки текста уникальны, при этом могут отличаться в своих окончаниях.
  Например :  ООО «Голд Тайм», ООО «Голд Тайм» / 1, ООО «Голд Тайм» / 2 и ООО «Голд Тайм» / 3;
2. В ячейке В1 шаблон для поиска значений в столбце А;
3. В столбец С нужны полученные, видимо формулой массива, отсортированные значения из столбца А попадающие под маску строки поиска из ячейки В1.
К сожалению, используется Эксель без поддержки формул работы с динамическими массивами.
Пример задачки во вложении.
Заранее спасибо )
 
D1 вставить формулу массива и протянуть до D17
Код
=ЕСЛИОШИБКА(СМЕЩ($A$1;НАИБОЛЬШИЙ((ЛЕВСИМВ($A$1:$A$17;ДЛСТР($B$1)-1)=ЛЕВСИМВ($B$1;ДЛСТР($B$1)-1))*СТРОКА($A$1:$A$17);СТРОКА(1:1))-1;0);"яяя")

С1 вставить формулу массива и протянуть до С17
Код
=ИНДЕКС($D$1:$D$17; ПОИСКПОЗ(НАИМЕНЬШИЙ(СЧЁТЕСЛИ($D$1:$D$17; "<"&$D$1:$D$17); СТРОКА(1:1)); СЧЁТЕСЛИ($D$1:$D$17; "<"&$D$1:$D$17); 0))
 
Для коллекции
Многоразовый ВПР (VLOOKUP)
 
Спасибо! То, что нужно)
Страницы: 1
Читают тему (гостей: 1)
Наверх