Страницы: 1
RSS
Смещение через 1 строку от предыдущей строки
 
Всем доброго времени суток, просьба помочь с формулой, самостоятельно не осилил.
Необходимые данные собираются в листе кор. 11.05.2022, где мы указываем дату и необходимые значения. На следующей строке от даты имеется корректировка, там уточненные значение от предыдущей строки.
Задача состоит в том, чтобы в листе факт 2022г. автоматически при перетаскивании формулы брались данные из листа кор.11.05.2022г. дата и значение по строке корректировка.
Для примера оставляю файл где данные через равно вставил, чтобы точно понять, что я хочу, а хотел бы автоматическую формулу через растягивание.
 
Работает, если даты писать нормально:
Код
=СМЕЩ(ИНДЕКС(Кор.11.05.2022!$B$1:$B$18;ПОИСКПОЗ(B2;Кор.11.05.2022!$B$1:$B$18;1);0);1;2)
Лучше пишите на почту)
 
формат дат поменять не возможно, если стоит к примеру 01.05-02.05.2022, его таи и надо оставить

Немного проясню ситуацию.
Необходимо, чтобы данные с листа кор.11.05.2022 попадали в лист факт 2022 через формулу и ее можно было протянуть как вниз так и вдоль строки, чтобы захватить все выделенные желтым цветом ячейки путем ее протягивания.

Даты аналогично должны проставляться автоматически через формулу, проскакивая строку корректировка
 
Возможно я правильно понял
Код
=ЕСЛИОШИБКА(ИНДЕКС(Кор.11.05.2022!F$1:F$30;АГРЕГАТ(15;6;СТРОКА(B$1:B$30)/(Кор.11.05.2022!$B$1:$B$30="Корректировка");СТРОКА(A1)));"")

Для дат вместо СТРОКА(A1)));"") надо СТРОКА(A1))-1);"")
Страницы: 1
Читают тему (гостей: 1)
Наверх