Страницы: 1
RSS
ВПР И ПОИСКПОЗ
 
добрый день, помогите найти ошибку в формуле, пожалуйста
Изменено: Людмила Сыч - 29.07.2022 21:37:00
 
формулу исправлять не нужно, ее нужно написать
в С5
Код
=ЕСЛИОШИБКА(ВПР($C$2;ДВССЫЛ($B5&"!A:C");СТОЛБЕЦ()-1;);0)
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
 
спасибо за подсказку
Изменено: Людмила Сыч - 29.07.2022 21:39:11
 
Цитата
Людмила Сыч написал:
а с поискпоз это может работать?
Может.
Код
=ЕСЛИОШИБКА(ВПР($C$2;ДВССЫЛ($B5&"!A:C");ПОИСКПОЗ(C$4;ДВССЫЛ($B5&"!A1:C1");););0)
 
Добрый вечер! Уже не первый день ломаю голову в чем может быть проблем? даже по новому таблицу сделала, но по истечению нескольких дней при вводе нового адреса на листе "Адреса" опять идет заполнение из других граф.
В данной таблице при выборе адресата на листах "Маленький" и др. все заполняется правильно автоматически, но если выбрать ГЛХУ "Сморгонский лесхоз" -заполняет не верный адрес. А в новой таблице при вводе нового адреса такая же проблема-вбивает автоматом вместо нужного адреса значения из других ячеек. В чем может быть проблема?
 
спасибо за помощь
 
Элона Шеверенко,  пробелы, обычное дело... Хотя пробел тут только при поиске всей ячейки играет.
А причина косяка в ИСТИНА в ВПР.
Изменено: Hugo - 29.07.2022 21:52:09
 
Цитата
написал:
Элона Шеверенко,  пробелы, обычное дело... И зачем там ИСТИНА в ВПР?
не понимаю. Где пробелы?
 
Это если искать поиском всю ячейку в адресах...
 
Цитата
написал:
Это если искать поиском всю ячейку в адресах...
что можно применить вместо истины в данном случаи?
 
Цитата
Элона Шеверенко написал:
что можно применить вместо истины в данном случаи?
0
 
Цитата
написал:
Цитата
Элона Шеверенко написал:
что можно применить вместо истины в данном случаи?
0
но в других же случаях работает истина.
 
Хелп по аргументам функции всё поясняет.
 
Цитата
написал:
но в других же случаях работает истина
когда уместно - работает
чтобы понимать в каких случаях нужно использовать последним параметром в ВПР ИСТИНА, а когда ЛОЖЬ написано в описании к функции
достаточно усвоить 1 раз и потом можно пользоваться всю жизнь
Программисты - это люди, решающие проблемы, о существовании которых Вы не подозревали, методами, которых Вы не понимаете!
Страницы: 1
Читают тему (гостей: 1)
Наверх