Страницы: 1
RSS
Как писать формулу СРЗНАЧЕСЛИ, если данные разбросаны по разным столбцам., Мне нужно вычислить среднее значение за исключением пустых ячеек и равных 0, но данные в разных столбцах.
 
Здравствуйте!

Мне нужно вычислить среднее значение за исключением пустых ячеек и равных 0, но данные в разных столбцах.
Проблема в том, что данные разбросаны по ячейкам разных столбцов. Соответственно, выделяя эти ячейки, я использую ; (точку с запятой), что указывает на аргумент, которых в этой формуле не может быть больше 3 и выдается ошибка
 
например, если данные находятся в диапазонах A1:A17, D1:D17 и F1:F17:
=СРЗНАЧ(ЕСЛИОШИБКА(1/(1/A1:A17);"");ЕСЛИОШИБКА(1/(1/D1:D17);"");ЕСЛИОШИБКА(1/(1/F1:F17);""))

это формула массива, вводится нажатием  Ctrl+Shift+Enter
Изменено: Бахтиёр - 24.11.2022 07:31:58
 
Евгений Вер, ну то что прежде чем задавать вопрос не плохо б ознакомится со справкой по функции, и тогда станет понятно что там за аргументы и почему их три и не более. А вот задав вопрос по другому и приложив пример, что вы там хотите, появится решение.
По вопросам из тем форума, личку не читаю.
 
Цитата
написал:
Евгений Вер, ну то что прежде чем задавать вопрос не плохо б ознакомится со справкой по функции, и тогда станет понятно что там за аргументы и почему их три и не более. А вот задав вопрос по другому и приложив пример, что вы там хотите, появится решение.
Здравствуйте!

Да, буду делать примеры. Справку читал, но так и не смог разобраться.

Спасибо
 
Цитата
написал:
например, если данные находятся в диапазонах A1:A17, D1:D17 и F1:F17:
 =СРЗНАЧ(ЕСЛИОШИБКА(1/(1/A1:A17);"");ЕСЛИОШИБКА(1/(1/D1:D17);"");ЕСЛИОШИБКА(1/(1/F1:F17);""))
 
это формула массива, вводится нажатием  Ctrl+Shift+Enter
Большое спасибо!!! Сейчас буду разбираться))
 
чуть короче:
=1/СРГАРМ(ЕСЛИОШИБКА(1/A1:A17;"");ЕСЛИОШИБКА(1/D1:D17;"");ЕСЛИОШИБКА(1/F1:F17;""))
 
=1/HARMEAN(IFERROR(1/CHOOSE({1\2\3};A1:A17;D1:D17;F1:F17);""))
=AVERAGE(IFERROR(1/(1/CHOOSE({1\2\3};A1:A17;D1:D17;F1:F17));""))
По вопросам из тем форума, личку не читаю.
 
Цитата
Евгений Вер написал:
Да, буду делать
И хде?
Кстати, очень сомневаюсь, что нужно произвольные диапазоны считать. Выбор столбцов может быть по шапке, выбор строк (если нужен) - по каким-то другим условиям. Все это почти всегда можно формульно посчитать. А вот для этого нужен максимально привязанный к реальному пример
Скажи мне, кудесник, любимец ба’гов...

 
Цитата
написал:
чуть короче:
 =1/СРГАРМ(ЕСЛИОШИБКА(1/A1:A17;"");ЕСЛИОШИБКА(1/D1:D17;"");ЕСЛИОШИБКА(1/F1:F17;""))  
Спасибо!!!
 
Цитата
написал:
=1/HARMEAN(IFERROR(1/CHOOSE({1\2\3};A1:A17;D1:D17;F1:F17);""))
=AVERAGE(IFERROR(1/(1/CHOOSE({1\2\3};A1:A17;D1:D17;F1:F17));""))
Спасибо!!!
 
Боже, каких-то функций нет...
СРГАРМ
СРГЕОМ
 
Еще вариант для коллекции.
=SUM(A1:A17;D1:D17;F1:F17)/INDEX(FREQUENCY((A1:A17;D1:D17;F1:F17);0);2)
 
Цитата
написал:
Еще вариант для коллекции.
=SUM(A1:A17;D1:D17;F1:F17)/INDEX(FREQUENCY((A1:A17;D1:D17;F1:F17);0);2)
Забираю в коллекцию) Спасибо!!!
Страницы: 1
Читают тему (гостей: 1)
Наверх