Страницы: 1
RSS
Подставление статуса по уникальному значению из разных таблиц
 
Всем привет!
Подскажите пожалуйста, у меня есть две таблицы, БД и Статус лист. В статус листе под каждой колонкой видов статусов к определенному уникальному значению стоит "Выполнено" или пусто, нужно что бы в таблицу на листе БД подставляло значение статуса (Статус 1, Статус 2 и т.д.) в зависимости стоит ли в конкретно этой колонке статуса и конкретной строке уникальному значению , значение "Выполнено". Пример есть в файле с примером результата но вручную.
 
Привет
что-то  в таком духе
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(ИНДЕКС('Статус лист'!B$2:E$8;ПОИСКПОЗ(A2;'Статус лист'!A$2:A$8;);)="Выполнено");'Статус лист'!B$1:E$1);"-")
 
Привет.
Вариант
=ЕСЛИОШИБКА(ИНДЕКС('Статус лист'!B$1:E$1;ПОИСКПОЗ("Выполнено";ИНДЕКС('Статус лист'!B$2:E$8;ПОИСКПОЗ(A2;'Статус лист'!A$2:A$8;0);0)));"")
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
Страницы: 1
Наверх