Страницы: 1
RSS
формула с объединением двух столбцов для упрощения работы, Мне надо из двух столбцов превратить в один и чтобы соблюдался порядок нужный.
 
в файле указано как должно получиться
 
Исходные данные всегда попарно идут?
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
 
В столбце А идет обозначение и они имеют оба направления, а данные из столбца В должны идти после 1-2 строк столбца А и.т.д
 
Цитата
написал:
Исходные данные всегда попарно идут?
Проще говоря это название двухсторонних бирок. 1-2 строка из столбца А это лицо, а столбец В это обратная сторона.  Таким образом нам надо чтобы получилось так как я выделил в файле
 
Простеньким макросом
Скрытый текст
Согласие есть продукт при полном непротивлении сторон.

Контакты, благодарности
 
Формула для Excel 365:
=ПОСТОЛБЦ(ГСТОЛБИК(СВЕРНСТРОК(A2:A99;2);СВЕРНСТРОК(B2:B99;2));1)

=TOCOL(HSTACK(WRAPROWS(A2:A99,2),WRAPROWS(B2:B99,2)),1)
 
Ещё формула:
Код
=ИНДЕКС(A$2:B$11;ОСТАТ(СТРОКА(D1)-1;2)+2*ОКРВВЕРХ(СТРОКА(D1)/4;1)-1;ЕЧЁТН(ОКРВВЕРХ(СТРОКА(D1)/2;1))+1)
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Всем огромное спасибо  
Страницы: 1
Наверх