Страницы: 1
RSS
Вывод данных по последнему заполнению в массиве
 
Здравствуйте! Подскажите пожалуйста как можно помимо просмотрх формулы найти данные по искомому значению среди массива данных, если изначально возвращаемый массив неизвестен? Известно только то, что возвращаемый массив столбца должен быть последним заполненным среди данных. Прикрепляю файл для примера, данные по месяцам, в столбце А находятся ФИО, поиск осуществляется по ним. Исходный лист остается без изменений, из него берутся данные. В конечном листе вернуть необходимо только тот столбец, который последний заполненный в исходном, без ориентирования по дате сверху.
 
jennybez,
можно тупо через доп столбец:
Код
=ПРОСМОТР("яяя";B2:K2;B2:K2)

можно так:
Код
=ИНДЕКС(Исходник!$B$2:$K$10;ПОИСКПОЗ($C$2;Исходник!$A$2:$A$10;0);ПОИСКПОЗ(МАКСЕСЛИ(Исходник!$B$1:$K$1;Исходник!$B$2:$K$2;"<>"&"");Исходник!$B$1:$K$1;0))
Изменено: evgeniygeo - 13.02.2024 19:19:27
 
Код
=IFERROR(
    LET(
        tbl, Исходник!A1:K10,
        r, XMATCH(C2, CHOOSECOLS(tbl, 1), 0),
        x, INDEX(tbl, r, 0),
        res, INDEX(x, XMATCH(TRUE, x <> "", 0, -1)),
        res
    ),
    "не найдено"
)
Пришелец-прораб.
 
=ГПР("яяя";ИНДЕКС(Исходник!B2:K10;ПОИСКПОЗ(C2;Исходник!A2:A10;););1)
=ВЗЯТЬ(ТЕКСТРАЗД(СЦЕП(ЕСЛИ(Исходник!A2:A10=C2;Исходник!B2:K10&"|";""));;"|";1);-1)
Изменено: Бахтиёр - 14.02.2024 10:19:20
 
evgeniygeo, AlienSx, Бахтиёр, спасибо большое вам! Ломала голову как реализовать, способы рабочие и очень полезны.
Страницы: 1
Наверх