Страницы: 1
RSS
Дублирование текста через привязку совпадений между ячейками, Необходимо настроить автоматическое дублирование текста в ячейки ниже по списку на основе совпадения значений параллельного списка
 
Здравствуйте!

Имеются два параллельно идущих столбца. В первом - старые артикулы составных частей изделий, во втором - новые артикулы.
Поскольку определенная доля составных частей изделий повторяется, было принято решение проверять список со старыми артикулами на наличие совпадений (помечается красным).

Вопрос: можно ли сделать так, чтобы при обнаружении повторного старого артикула рядом с ним автоматически вписывался новый артикул, который уже был применен выше по списку к тому же старому артикулу?

Заранее благодарю!  
 
можно
 
Цитата
написал:
можно
И как? Можно инструкцию?
 
Цитата
Rinum написал:
Можно инструкцию?
можно. Обратите особое внимание на пункт 2.3
Изменено: AlienSx - 12.03.2024 15:28:12
Пришелец-прораб.
 
Цитата
написал:
Обратите особое внимание на пункт 2.3
Существует такая прекрасная вещь, как статья 183 УК РФ о неразглашении коммерческой тайны. Согласно ей, я не имею права передавать какие-либо данные, с которыми работаю. Увы, не все, кто сталкивается в своей жизни с Exel - бухгалтера и статисты, бывают и исключения. А отдельно создавать документы для примера времени и желания не слишком много.
Проблему расписал максимально подробно. Не утверждаю "на все сто", но мне кажется, такую несложную функцию, как поиск совпадений и работа с совпадениями, разработчики программы предусмотрели. А я не знаю, как ею воспользоваться в силу неопытности, и надеюсь получить ответ и решение своей проблемы здесь.
Так что не стоит тыкать в нос правилами форума, если какой-то пункт не выполнен. Он не выполнен по объективной причине, а не по незнанию)
 
Цитата
написал:
А отдельно создавать документы для примера ... желания не слишком много.
Очевидно, Вы предполагаете, что у кого-то создать пример для решения Вашей задачи желания больше.
Я не настаиваю на создании примера, только констатирую, что вижу в ветке.
 
Без примера - ВПР в помощь.
офф
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
 
Цитата
написал:
Очевидно, Вы предполагаете, что у кого-то создать пример для решения Вашей задачи желания больше.
Я никого не просил и не предлагать создавать что то. Можно просто указать на необходимое действие/последовательность действий)
Вопрос я постарался сформулировать максимально подробным и простым языком.
Насколько я понимаю, форум - это место, где люди отвечают на вопросы абсолютно добровольно, а не служба поддержки с недовольными жизнью сотрудниками.
Если не понятен вопрос - можно уточнить что то, или просто проигнорировать, а не тыкать правилами.
В конце концов, он был задан не в формате "памагити, не палучаца!")
 
Код
=ЕСЛИОШИБКА(ВПР(A3;$A$1:B2;2;0);"")
 
Цитата
написал:
Код=ЕСЛИОШИБКА(ВПР(A3;$A$1:B2;2;0);"")
Премного благодарен!
 
Здравствуйте!

Полученных ответов не хватило, решил попробовать задать вышеописанный вопрос еще раз через конкретный пример. Возможно, результативность улучшится)

Итак, имеем два параллельных столбца: случайно наклацанные числа и также случайно наклацанные слова. Столбцы идут параллельно и периодически значения первого столбца дублируются (при помощи правила автоматически помечаются красным).

Мне необходимо создать формулу, чтобы при вписывании чисел в ячейки ниже, автоматически искались совпадения в диапазоне выше по списку. То есть, я вписываю число в А35, и мне нужно, чтобы осуществился поиск совпадений в диапазоне А1-А34. В случае обнаружения совпадения значение из соседней ячейки, соответствующее найденному совпадению должно быть помещено в ячейку с тем же номером, что и искомая.

Пример:

В ячейку А35 я вписываю число 1111. Этому числу соответствует слово "Кошка", которое должно быть вписано в ячейку С35.
Число 1111 уже встречается, например, в ячейках А5, А10, А31. Соответственно, рядом с этим числом во всех ячейках с буквой "С" и теме же номерами вписано слово "Кошка".
Мне нужна формула, по которой будет осуществлен поиск числа 1111 в диапазоне А1-А34 и, обнаружив совпадение, в ячейку С35 автоматически впишется слово "Кошка".

Также требуется, чтобы диапазон поиска постоянно расширялся вниз по списку(то есть, при вписывании в А36 диапазон был бы А1-А35, в А37 - А1-А36 и т.д).

В голове понимаю, какие команды должны применятся, но никак не могу выстроить логическую формулу, соответствующую всем требованиям. Надеюсь, решение не будет содержать продажу души дьяволу за какой-нибудь макрос)

Надеюсь, что данных разъяснений хватит для более-менее ясного ответа, достаточного для решения задачи.

Заранее благодарен!
 
Сейчас рискуем опять вызвать гнев у ТС, спровоцируем угрозы вроде
Цитата
написал:
как статья 183 УК РФ
но что это, #@#, за пример.
Цитата
написал:
В ячейку А35 я вписываю число 1111. Этому числу соответствует слово "Кошка",
В примере нет числа 1111, нет слова "Кошка". Хотя по утверждению ТС
Цитата
написал:
Число 1111 уже встречается, например, в ячейках А5, А10, А31. ... рядом с этим числом во всех ячейках ... вписано слово "Кошка".
В примере столбец А вообще пустой.

Всё ерунда, Миша, давай по новой!
 
Цитата
написал:
Всё ерунда, Миша, давай по новой!
Что ж, большего, собственно, и не ожидалось.
Разумеется, времени у Вас не так много, чтобы посидеть и подумать (хотя бы чуть-чуть). Но его вполне достаточно, чтобы писать ересь, приправляя ее цитатами из мемов. Ой, простите, цитатой, вы же только одну приложили (чтобы не допустить неточностей)!

Если вы все-таки находитесь здесь по принуждению, моргните два раза, я постараюсь Вам помочь.

Всего лучшего!
 
 
У Вас времени видимо вообще в обрез, что-бы посидеть и сделать нормальный файл-пример. Как есть - Как надо.
Замените Ваши патроны/пулемёты на бананы/апельсины.
Вообще-то это нужно ВАМ, а Вы тут файлы на 'отвали' рисуете, еще и хамите помогающим
Согласие есть продукт при полном непротивлении сторон
 
Цитата
написал:
Но его вполне достаточно, чтобы писать ересь,
Забавно. Процитировал слова ТС; написал, что у него в примере находится. Автор завопил "Вы пишете ересь!". Да я от себя-то почти ничего не добавил )
Страницы: 1
Наверх