Страницы: 1
RSS
Определить, количество, определенных последовательностей.
 
Уважаемые форумчане, прошу Вас решить следующую проблему.

1. Определить сколько раз, выполнилось условие, в данном случае последовательность "2,2".
При том что ячейки, которые уже выполнили условие, не участвую в даннейшей выборки.
Это можно наблюдать с ячейками В4 и В5 , они выполнели условие и В3 уже не может выполнить условие с B4.
Выборка начинаеть с конца.
2. Определить сколько ходов назад, выполнилось условие "2,2" от начальной ячейки (B2)

Пример прилагаю.
Зараннее благодарен.
 
chelovekov81,
Код
С2:  =ЕСЛИ(И(B2=2;B3=2;C3="");МАКС(C3:$C$27)+1;"")
E2:  =МАКС($C$2:$C$27)
A2:  =ЕСЛИ(И(B2=2;B1=1);1;"")
E7:  =ПОИСКПОЗ(1;$A$2:$A$27;0)-1
Изменено: evgeniygeo - 02.04.2024 05:56:42
 
Спасибо огромное.
Немного потестировал, и выявил что с если, условий три, формула работает не корректно.
Если можно поправте пожалуйста.

Пример прилагаю.
Заранее благодарен.
Изменено: chelovekov81 - 02.04.2024 06:42:44
 
chelovekov81, здравствуйте. Какая версия Excel?
 
2021
 
chelovekov81,
а как еще могут измениться условия?
попробуйте так:
Код
С2:   =ЕСЛИ(И(A2=2;A3=2;A4=2;C3="";C4="");МАКС(C3:$C$27)+1;"")

или макросом:
Код
Sub aaa()
Columns("B:B").Clear
lLastRow = Cells(Rows.Count, 1).End(xlUp).Row
For r = lLastRow - 2 To 2 Step -1
    If Cells(r, 1) = 2 And Cells(r + 1, 1) = 2 And Cells(r + 2, 1) = 2 And Cells(r + 1, 2) = "" And Cells(r + 2, 2) = "" Then
        Cells(r, 2) = Application.Max(Range(Cells(r, 2), Cells(27, 2))) + 1
        Range(Cells(r, 2), Cells(r + 2, 2)).Merge
        Range(Cells(r, 2), Cells(r + 2, 2)).HorizontalAlignment = xlCenter
        Range(Cells(r, 2), Cells(r + 2, 2)).VerticalAlignment = xlCenter
    End If
Next
End Sub
Изменено: evgeniygeo - 02.04.2024 09:16:08
 
Вариант. На листе Вариант).
 
Код
=(ДЛСТР(СЦЕП(A2:A26))-ДЛСТР(ПОДСТАВИТЬ(СЦЕП(A2:A26);"222";"")))/3
 
Тимофеев, к несчастью не у всех новые функции доступны. Желательно указывать версию

Массивка
=SUM(INT(FREQUENCY(IF(A2:A26=2;ROW(A2:A26));IF(A2:A26<>2;ROW(A2:A26)))/3))

Примечание, для решения задачи не важно от куда начинать считать тройки, то что написано начинать с конца только запутывает.
По вопросам из тем форума, личку не читаю.
 
Еще вариант для Excel 2021+:
Скрытый текст
 
Всем спасибо !!!  :)

Я в шоке, всех благ Вам ребята.
Страницы: 1
Наверх