Страницы: 1
RSS
Как при обращении к столбцу умной таблицы задать его название через формулу?
 

Подскажите, возможно ли при обращении к столбцу умной таблицы задать его название (которое в квадратных скобках пишется) через формулу?

Пример: обычное обращение к столбцу умной таблицы выглядит следующим образом: =Таблица1[месяц] . А можно ли взять слово "месяц" из какой-нибудь ячейки и подставить в квадратные скобки? Что-то вроде этого: =Таблица1[=$A$1] ??

 
Почитайте про функцию ДВССЫЛ.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
Максим В., я знаю про эту функцию. Но не понимаю как её в данном случае применить? Куда её вписать? Вот так, например:  =Таблица1[ДВССЫЛ()] работать не будет. Так как ей воспользоваться?
 
Палкой Влагу, файл пример покажите.
Если в мире всё бессмысленно, — сказала Алиса, — что мешает выдумать какой-нибудь смысл? ©Льюис Кэрролл
 
=ДВССЫЛ("Таблица1["&A1&"]")

=ИНДЕКС(Таблица1;0;ПОИСКПОЗ(A1;Таблица1[#Заголовки];0))
Изменено: Бахтиёр - 04.04.2024 12:17:15
 
Цитата
Палкой Влагу: Вот так, например:  =Таблица1[ДВССЫЛ()] работать не будет.
очень странно, ведь тут прекрасно понятно, какой столбец из Таблица1 нужно брать …  :(
Во всех делах очень полезно периодически ставить знак вопроса к тому, что вы с давних пор считали не требующим доказательств (Бертран Рассел) ►Благодарности сюда◄
 
=INDEX(Таблица1, , MATCH(A1, Таблица1[#Headers]))
Пришелец-прораб.
 
Бахтиёр, то что надо. Спасибо.
Страницы: 1
Наверх