Страницы: 1
RSS
Подтянуть числовое значение по трем параметрам
 
Приветствую, товарищи! Нужна Ваша помощь.

Есть таблице есть "БД Датчики". В ней содержится информация о том, какое кол-во датчиков в какой ячейке находится.

Необходимо подтянуть числовое значение из таблицы "БД Датчики" по выбранному наименованию изделия из выпадающего списка по конкретной ячейке хранения и "Объему материалов".

Конечный вид в листе "Что должно быть".

Заранее благодарю Вас!
 
Здравствуйте Алексей Корепанов,
Так надо?
=СУММПРОИЗВ(('БД Датчики'!$A$2:$A$25=$C$2)*('БД Датчики'!$B$1:$L$1=$A5)*'БД Датчики'!$B$2:$L$25)
и для объёма материала:
=ВПР($C$2;'БД Датчики'!$A$2:$M$25;13;)
 
Алексей Корепанов,
Код
=SUMPRODUCT(('БД Датчики'.$B$2:$L$25)*('БД Датчики'.$A$2:$A$25=$C$2)*('БД Датчики'.$B$1:$L$1=$A5)*('БД Датчики'.$M$2:$M$25=B$4))
 
Друзья, благодарю Вас за помощь!
 
Однако решение Сводной таблицей мне видится более наглядным и практичным, да и не нужно будет выпадающий список корректировать со временем и формулу писать не нужно :))
 
До кучи. Как вариант (массивная):
UPD. Не обратил внимание на "Объём материала". Так правильно:
=ИНДЕКС('БД Датчики'!$B$2:$M$25; ПОИСКПОЗ($C$2;'БД Датчики'!$A$2:$A$25;); ПОИСКПОЗ(A4;'БД Датчики'!$B$1:$M$1;))
Изменено: Muxa K - 15.05.2024 15:46:32
Страницы: 1
Наверх