Страницы: 1
RSS
Вывести номер автомобиля, Вывести номер автомобиля в отдельный столбик
 
Доброго денечка!

Помогите пожалуйста, нужно вынести номер автомобиля в отдельный столбик (данные во вложении, столбик D), как это можно сделать быстро минимизировав ошибки? Работаю с Cnrl+E но часто ложатся некорректные данные... 😢
За ранее спасибо!
 
разделяете столбец по пробелу, соединяете лишнее обратно )
 
Код
=ЕСЛИ(ЕОШ(ЗНАЧЕН(СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));100))));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));100));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));200)))
 
МатросНаЗебре, останется только в предпоследней строке ручками подправить и проверить всё остальное тщательно
 
Цитата
написал:
=ЕСЛИ(ЕОШ(ЗНАЧЕН(СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));100))));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));100));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));200)))
ОГРОМНОЕ СПАСИБО!!!!! Вы гений!))))))
 
Цитата
написал:
разделяете столбец по пробелу, соединяете лишнее обратно )
Долго, но спасибо за один из вариантов)))
 
Цитата
написал:
=ЕСЛИ(ЕОШ(ЗНАЧЕН(СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));100))));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));100));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(C2;" ";ПОВТОР(" ";100));200)))
Подскажите пожалуйста, а что нужно заменить в формуле, что бы получилось в таблице во вложении (получается там номер с пробелами)
 
Код
=ЕСЛИ(ДЛСТР(СЖПРОБЕЛЫ(ЛЕВСИМВ(ПРАВСИМВ(ПОДСТАВИТЬ(D3;" ";ПОВТОР(" ";100));400);100)))=1;
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(D3;" ";ПОВТОР(" ";100));400));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(D3;" ";ПОВТОР(" ";100));300)))
 
Цитата
написал:
=ЕСЛИ(ДЛСТР(СЖПРОБЕЛЫ(ЛЕВСИМВ(ПРАВСИМВ(ПОДСТАВИТЬ(D3;" ";ПОВТОР(" ";100));400);100)))=1;
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(D3;" ";ПОВТОР(" ";100));400));
СЖПРОБЕЛЫ(ПРАВСИМВ(ПОДСТАВИТЬ(D3;" ";ПОВТОР(" ";100));300)))
Благодарю Вас! Отличного дня!
 
Примените два раза Cnrl+E и только останеться поправить предпоследнийй номер в таблице.
 
Цитата
нужно вынести номер автомобиля в отдельный столбик
UDF
Код
Function AvtoNomer(cell$)
 With CreateObject("VBScript.RegExp")
     .Pattern = "[А-Я]{1,3}\s\d{3,4}\s([А-ЯA-Z]{1,3})?\s?(\d{2,3})?"
     .Global = True
   If .test(cell) Then
     AvtoNomer = .Execute(cell)(0)
   Else
     AvtoNomer = ""
   End If
 End With
End Function
 
Karma, так можно формула для первого и вторго файла
Код
=ПСТР(C2;ПРОСМОТР(99;ПОИСК(" "&ЛЕВБ(ПРАВБ(ПОДСТАВИТЬ(C2;" ";);{8;9}));C2))+1;99)
=ПСТР(D3;ПРОСМОТР(99;ПОИСК(" "&ЛЕВБ(ПРАВБ(ПОДСТАВИТЬ(D3;" ";);{8;9}));D3))+1;99)

PS. В авто номерах русских букв не бывает.

В первом файле "Мерседес Спринтер С448ВА39" русская, потому ошибка

Алексей М.
 
Еще вариант для первого и второго файла. Разница только в ссылке
Код
=ПСТР(C2;ПРОСМОТР(99;ПОИСК(" "&ЛЕВБ(ПРАВБ(C2;{8;9;10;11});8);C2))+1;99)
=ПСТР(D3;ПРОСМОТР(99;ПОИСК(" "&ЛЕВБ(ПРАВБ(D3;{8;9;10;11});8);D3))+1;99)

Так меньше ошибок, а может быть и нет.

Алексей М.
Страницы: 1
Наверх