Страницы: 1
RSS
Формула сложного ВПР с вложением, ВПР с пропорциональным распределением
 
Добрый вечер!

Необходимо взять баллы из правой таблицы и распределить их пропорционально годам в левой таблице.


Подскажите, пожалуйста, есть ли простое решение для вложенного примера. Число школ может быть не более 10.
Нужно получить столбец D (итоги для наглядности).
Сама решение нашла, но ооооочень уж громоздкое.
Изменено: Valgreat - 14.05.2024 18:51:57
 
Вот так, например:
Код
=ОКРУГЛ(ВПР(A2;$I$2:$J$5;2;0)*СУММЕСЛИМН($C$2:$C$9;$A$2:$A$9;A2;$B$2:$B$9;B2)/СУММЕСЛИ($A$2:$A$9;A2;$C$2:$C$9);0)

Только номера надо продлить по столбцу, чтоб не было пустых ячеек. Умеете продлевать не вручную?
Изменено: Дмитрий Никитин - 14.05.2024 19:44:32
Шлюхогон42
 
Спасибо! Не подумала в сторону этой функции.
Страницы: 1
Наверх