Страницы: 1
RSS
Пересчитать все совпадения в таблице по двум условиям
 
Есть список ФИО и результатов запроса по каждому из них...
- ФИО сотрудников около 500-600
- возможных результатов для каждого 5.

Как из левой таблицы в файле сделать правую?
Все ФИО в алфавитном порядке, напротив каждой фамилии посчитано сколько у него было каждого вида результатов
 
Создайте сводную таблицу. Столбец ФИО в строки,  столбец Результаты в столбцы, а в значения - снова столбец ФИО с параметром количества записей
 
Код
C4:C11    =ЕСЛИОШИБКА(ВПР(A4;A$1:C3;3;0);МАКС(C$1:C3)+1)
D4:D11    =ЕСЛИОШИБКА(ВПР(B4;B$1:D3;3;0);МАКС(D$1:D3)+1)
E4:E7    =ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$11;ПОИСКПОЗ(СТРОКА(1:1);C:C;0));"")
F3:I3    =ЕСЛИОШИБКА(ИНДЕКС($B$1:$B$11;ПОИСКПОЗ(СТОЛБЕЦ(A:A);$D:$D;0));"")
F4:I7    =СЧЁТЕСЛИМН($A:$A;$E:$E;$B:$B;$3:$3)

А лучше почитайте про сводные таблицы. Возможно, этот инструмент подойдёт.
Изменено: МатросНаЗебре - 16.05.2024 09:48:06
Страницы: 1
Наверх