Страницы: 1
RSS
Совместная формула ЕСЛИ+ВПР, Необходима формула для нескольких условий
 
Добрый день!

Возникла сложность с составлением формулы.
Описание проблемы:
Есть таблица (во вложении), необходимо в первый лист "Регионы" в ячейку B2 по значению B1 (наименование программы) перенести значение из листа "Согласование". Условие, если на листе "Согласование" в ячейке E2 есть значение, то оно переносится на лист "Регионы" в ячейку B2, если в ячейке E2 пусто, то переносится значение из ячейки C2.
Как я понял, необходима формула типа (приблизительная) =ЕСЛИ(Е2>0;ВПР(В1;Диапазон листа "Согласование";5;0);ВПР(В1;Диапазон листа "Согласование";3;0))
Но данная формула по умолчанию выдаёт только значение из ячейки E2, даже пустое значение
 
Логика другая - если впр из е2 возвращает >0, то оставляем, иначе впр из С2
Наверняка можно упростить, и ещё навесить еслиошибка()
P.S. хотя нет ошибок:
Код
=ЕСЛИ(ВПР(B1;Согласование!$A:$E;5;0)>0;ВПР(B1;Согласование!$A:$E;5;0);ВПР(B1;Согласование!$A:$E;3;0))
Изменено: Hugo - 16.05.2024 16:02:51
 
Код
=ВПР(B$1;Table114;5+(3-5)*ЕПУСТО(ВПР(B$1;Table114;5;0));0)
 
Цитата
написал:
=ВПР(B$1;Table114;5+(3-5)*ЕПУСТО(ВПР(B$1;Table114;5;0));0)
Благодарю!
Эта формула помогла.

Спасибо большое!
Страницы: 1
Наверх