Страницы: 1
RSS
Непустые ячейки текстового формата содержащие цифры
 
Здравствуйте. Сделал с горем пополам две книги. В книге 2 в столбце Е заполняются данные из книги 1 из столбца А, при этом берутся непустые ячейки. Но я никак не могу добиться того что бы брались не только непустые, а только те, которые содержат цифры. Причем неважно какой формат ячейки и с каким разделителем цифры.


В книге 2 в столбце Е использую формулу массива:
=ЕСЛИОШИБКА(ДВССЫЛ("'["&$A$2&".xlsx]"&"Смета"&"'!"&"A"&НАИМЕНЬШИЙ(ЕСЛИ(ЕПУСТО(ДВССЫЛ("'["&$A$2&".xlsx]"&"Смета"&"'!"&"$A$"&$B$3&":$A$999"));"";СТРОКА(ДВССЫЛ("'["&$A$2&".xlsx]"&"Смета"&"'!"&"$A$"&$B$3&":$A$999")));СТРОКА(A1)));"")

Пытаюсь что-то придумать с использованием СЧЁТ(ПОИСК({1:2:3:4:5:6:7:8:9:0};A1))>0 или СЧЁТ(ПОИСК({1:2:3:4:5:6:7:8:9:0};A1))=0. Ничего не получается.


Прошу помощи. Как сделать что бы в книге 2 в столбце Е были только цифры?
Изменено: rain_day - 08.06.2024 09:01:26
 
вариант
{}
=ЕСЛИОШИБКА(ИНДЕКС(ДВССЫЛ("["&A$2&".xlsx]Смета!A1:A999");НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЛЕВСИМВ(ДВССЫЛ("["&A$2&".xlsx]Смета!A"&B$3&":A999")));СТРОКА(ИНДЕКС(A:A;B$3):A$999));СТРОКА(A1)));"")
21-й офис
=LET(_а;ДВССЫЛ("["&A$2&".xlsx]Смета!A"&B$3&":A999");ФИЛЬТР(_а;ЕЧИСЛО(1/ЛЕВБ(_а))))
 
Павел \Ʌ/, спасибо Вам, работает великолепно, но с одной интересной загадкой. Как Вы понимаете имя книг 1 и 2 это для примера. На самом деле они имеют названия типа 01-01-02. Так вот с такими именами книг перестаёт работать. При чем старая формула работает, а новая вообще не видит книгу-источник

Если книгу 1 переименовать в "01-01-02.xlsx", а в книге 2 в ячейке А2 указать имя "01-01-02" - ничего не работает
Если книга называется "1.xlsx", а в книге 2 в ячейке А2 указать имя "1" - всё работает

Будьте добры, подскажите как сделать что бы не было ограничений на имя книги. Их много, и имена у них все разные. Переименовывать не вариант
Изменено: rain_day - 08.06.2024 13:19:57
 
Цитата
но с одной интересной загадкой. Как Вы понимаете имя книг 1 и 2 это для примера. На самом деле они имеют названия типа 01-01-02
Загадку эту разгадать , думаю, не сложно будет вам, если сошлётесь на какую-нибудь ячейку в книге "01-01-02" и внимательно посмотрите на получившуюся ссылку...
...
=[1.xlsx]Смета!$A$26
='[01-01-02.xlsx]Смета'!$A$26
Добавьте в формуле то чего не хватает
Изменено: Павел \Ʌ/ - 08.06.2024 13:30:39
 
Павел \Ʌ/, спасибо, учитель! ) Я допёр, всё получилось

А в чем прикол, почему апостроф к определённым именам книг присваивается, а к другим нет?
Изменено: rain_day - 08.06.2024 13:41:31
 
Цитата
rain_day написал:
А в чем прикол
в символах вроде тире и пробелов(и еще куча других), которые являются специальными или служебными. Если хотя бы один такой символ есть в имени листа, книги или в пути к файлу - добавляется апостроф.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
Страницы: 1
Наверх