Страницы: 1
RSS
Формула с отсчетом даты до события, Пытаюсь сделать формулу с отсчетом даты до события
 
Пытаюсь сделать формулу с отсчетом даты до события
Важно что при наступлении события и выполнении условий ячейка бы закрашивалась в цвет и писался результат события.
Пример и условия выкладываю в файл
 
для какой ячейки из 24 нужна формула? )
 
нужно 3 формулы - они схожи. Формула 1, формула 2, формула3. Суть каждой расписана)
 
строчка G2, H2, I2
G2 я уже попробовал сделать но не до конца получается
 
внизу подписано что должна выполнять формула 1, формула 2 и формула 3 слева направо
 
krs05, вложенными ЕСЛИ не пробовали?
попробуйте создать блок-схему примерно как здесь , глядишь, что-то да и прояснится  ; )
 
Cоставил схему
 
Цитата
krs05,   Cоставил схему
И что не получается? Начните с   =ЕСЛИ(A2="";"";ЕСЛИ(B2=""; ЕСЛИ(  ...   ) ; ЕСЛИ(  ...   ) ) )
Потом не стоит в одной теме несколько вопросов поднимать (это я про условное форматирование)
 
Вроде сделал - не могу только сообразить как сделать чтобы формула например =B2-(A2+10) дней - считалась в тексте.
Помогите пожалуйста
 
Цитата
krs05 написал:
чтобы формула например =B2-(A2+10) дней - считалась в тексте
"Срок нарушен на "&B2-(A2+10)&" дн."
 
Цитата
написал:
"Срок нарушен на "&B2-(A2+10)&" дн."
Спасибо!
 
Цитата
krs05:   Вроде сделал...
ну вот же ж - молодцом  ;)
Обычно не хочется браться за подобные задачи поскольку "нудноваты", да еще и логика не совсем ясна
чуть поджал:
=ЕСЛИ(ЕСЛИ(B2="";СЕГОДНЯ();B2)-A2>10;"Срок нарушен на "&ЕСЛИ(B2="";СЕГОДНЯ();B2)-A2-10&" дней";ЕСЛИ(ИЛИ(B2="";B2-A2>10);"Осталось "&A2+10-СЕГОДНЯ()&" дней";"Срок соблюден"))
Страницы: 1
Наверх