Страницы: 1
RSS
Вычисление нарастающих итогов по нескольким условиям
 
Добрый день, прошу помощи, не могу додумать как переформировать формулу, для расчета нарастающих итогов, в том случае, если номер проекта может повториться, но с другими значениями. Хочу, чтобы он считал их сумму. Например, выставляем в b2 январь - то в b5 должно выйти 69 и так далее. В данный момент из-за использования связки index и match excel выводит первое подходящее значение. Пример в файле прилагаю, спасибо!
 
Здравствуйте.
Попробуйте такую формулу
Код
=СУММЕСЛИ($H$2:$H$7;A3;ИНДЕКС($I$2:$T$7;;ПОИСКПОЗ($B$2;$I$1:$T$1;)))
 
Огромное спасибо за помощь!
 
Цитата
написал:
Здравствуйте.Попробуйте такую формулу
Код=СУММЕСЛИ($H$2:$H$7;A3;ИНДЕКС($I$2:$T$7;;ПОИСКПОЗ($B$2;$I$1:$T$1;)))
Еще раз здравствуйте, а куда стоит копать, если эти вычисления нужно соединить, чтобы был расчет по строке и столбцу.Нобходимо расчитать нарастающие траты на текущий месяц
 
Kr9ka, делайте месяцы датами, и тогда можно считать по условию больше-меньше.
Т.е. суммировать все в строке с Ru-744  которые меньше или равно февралю.
А с такими данными - лишний гемор, хотя конечно тоже можно написать формулу, но сложнее.
P.S.в файле просто пронумеровал месяцы, ставьте даты и выводите форматом название месяца.
Изменено: Hugo - 08.07.2024 09:47:46
 
Здравствуйте
так?
=СУММПРОИЗВ((H$2:H$7=A3)*I$2:ИНДЕКС(I$7:T$7;ПОИСКПОЗ(B$2;I$1:T$1;)))
 
Цитата
написал:
А с такими данными - лишний гемор, хотя конечно тоже можно написать формулу, но сложнее.
Здравствуйте, спасибо за рекомендацию! С числами и правда все стало проще
 
Цитата
написал:
Здравствуйтетак?=СУММПРОИЗВ((H$2:H$7=A3)*I$2:ИНДЕКС(I$7:T$7;ПОИСКПОЗ(B$2;I$1:T$1;)))
Здравствуйте, через SUMPRODUCT можно и так:
=SUMPRODUCT(($H$2:$H$8=A3)*($I$2:$T$8)*($I$1:$T$1<=$B$2))
Но тут опять же, если дата записана буквами, то некорректно будет работать, более менее выход в файле
Страницы: 1
Наверх