Страницы: 1
RSS
Задать условие для ячейки по значениям нескольких ячеек
 
Уважаемые Дамы и Господа, добрый день. Подскажите как прописать функцию, чтобы в ячейкe N12 учитывались данные ячеек Q12, M12 и К12. Я написал формулу через функцию ЕСЛИ. Как написать формулу, чтобы при значении ячейки M12="U" + Q12="C"+Q12="P"+К12<50, значение ячейки N12 выводило RA to be prepared". Пример прикрепил. Заранее благодарю.  
 
Я правильно понял, что должны выполняться все условия?

M12="U"
Q12="C"
Q12="P"
К12<50

Если да - то, во-первых, Вы в двух условиях указали ячейку Q12. Исправьте на нужный столбец.
Во-вторых, попробуйте сперва написать формулу И, где перечислены все нужные условия, а её уже использовать в формуле Если
Изменено: DAB - 05.07.2024 21:43:53
 
Если условие выполнения:
К12<50
M12="U"
Q12="C" или "P"

то в N12 последнее ЕСЛИ:

ЕСЛИ(И(M12="U";ИЛИ(Q12="C";Q12="P");K12<50);"RA to be prepared";"выбери Q")

P.S. При М="U" и Q="пусто" N=ЛОЖЬ (ошибка) - см. строку 19 - формула учитывает не все варианты (как мне кажется).

P.P.S. В "шапке" таблицы многострочность заголовков достигается пробелами. Может, для переноса строки лучше использовать сочетание клавиш Alt+Enter?
Изменено: Михаил Нарвич - 08.07.2024 08:47:30
 
Можно ведь перемножать условия
 
Цитата
Hugo написал:
Можно ведь перемножать условия

Интересно! Можно ссылку на пример?
 
Цитата
Михаил Нарвич написал:
Можно ссылку на пример?

Код
=ЕСЛИ(M12="";"";ЕСЛИ(M12="A1";0,5+0,01*K12;ЕСЛИ(M12="A2";1+0,02*K12;ЕСЛИ(M12="B";1+0,02*K12;ЕСЛИ(M12="C";2+0,05*K12;ЕСЛИ(M12="D";2+0,08*K12;ЕСЛИ((M12="U")*(((Q12="C")+(Q12="P"))>0)*(K12<50);"RA to be prepared";"выбери Q")))))))

Но что-то там в условиях нужно уточнять, в 19й строке косячит.
Последнее можно чуть короче:
Код
ЕСЛИ((M12="U")*((Q12="C")+(Q12="P"))*(K12<50);"RA to be prepared";"выбери Q")
Изменено: Hugo - 08.07.2024 00:16:25
 
Цитата
Hugo написал:
Последнее можно чуть короче: ...

Интересный ход!
По сути всё ясно: заменяем И на "умножить", ИЛИ на "сложить". Но с точки зрения читабельности чужой формулы - я бы не "врубился" - непривычно.
 
Такой подход стандартный для массивной СУММ() по условиям, да и для СУММПРОИЗВ() сильно расширяет возможности.
Да и вообще много где можно применять.
Например ищем 1 в ПОИСКПОЗ()
Изменено: Hugo - 08.07.2024 00:26:15
 
Hugo, спасибо за подсказку!
Страницы: 1
Наверх