Страницы: 1
RSS
Подсчет количества уникальных значений в диапазоне
 
Товарищи, всем доброго дня.
Прошу у Вас помощи, с очередным вопросом по экселю. не даётся он мне без боя.
суть вот в чем: у меня есть огромный массив данных, мне надо по 2м критериям поиска, найти число уникальных найденных значений.
Да, я понимаю как сделать отсеивание, как посчитать количество ячеек, но как посчитать количество уникальных значений, я не пойму. покопался на форуме и варианты которые там нашел, не работают (ну или у меня не работают).

в итоге должно по идеи получаться следующее например: в 1977 году скорость 12 и более фиксировалась 7 раз, 1 и 2 числа, это значит итоговое значение 2 дня.

Помогите решил проблему
 
Странник123, вам формулой надо или...? И в какой версии экселя?
пока так (21-й):
=СЧЁТ(1/(УНИК(ФИЛЬТР(B1:B39;(A1:A39=F1)*(C1:C39=F2)))<>""))
 
В ЭТОЙ теме есть UDF
Согласие есть продукт при полном непротивлении сторон
 
Цитата
написал:
вам формулой надо или...? И в какой версии экселя?пока так (21-й):=СЧЁТ(1/(УНИК(ФИЛЬТР(B1:B39;(A1:A39=F1)*(C1:C39=F2)))<>""))
Да, формулой, эксель 2016, там нет УНИКа. Находил уже на форуме про уник, думал вот оно...но...эксель 2016 умеет обламывать.  
Изменено: Странник123 - 09.07.2024 04:04:26
 
Цитата
написал:
В  ЭТОЙ теме  есть UDF
Я с UDF еще не разу не работал. Но вроде добавил функцию, после нашел её в категории "определенные пользователем", далее в RngU добавил диапазон где нужно искать уникальные значения соответствующие критериям поиска (B1:B38), а в Conditions добавил критерии поиска (A1:A38=F1 и C1:C38>F2), но нифига, пишет ЗНАЧ. Что я делаю не так?  
 
Может так (массивная формула для 2016):
=СЧЁТ(1/((A1:A39=F1)*(C1:C39=F2)*(ПОИСКПОЗ(C1:C39&B1:B39;C1:C39&B1:B39;)=ROW(B1:B39))))
 
Еще возможность, не требующая массивного ввода:
=СУММПРОИЗВ((A1:A39=F1)*(C$1:C$39=F2)/СЧЁТЕСЛИМН(A1:A39;A1:A39;C1:C39;C1:C39;B1:B39;B1:B39))
Изменено: Павел \Ʌ/ - 09.07.2024 12:37:05
 
Цитата
написал:
Еще возможность, не требующая массивного ввода:=СУММПРОИЗВ((A1:A39=F1)*(C$1:C$39=F2)/СЧЁТЕСЛИМН(A1:A39;A1:A39;C1:C39;C1:C39;B1:B39;B1:B39))
Павел, спасибо Вам огромное!!! Всё заработало. Вы не представляете как мне помогли. еще раз огромнейшее спасибо! А так же спасибо всем кто откликнулся на помощь, всем крепко жму руку.  
 
Павел \Ʌ/, не доходит как в данном случае работает СЧЕТЕСЛИ(МН) Спец вынес отд столбец только с одним критерием и так считает по диапазону ка-то по иному   Я так понимаю ищет кол-во значений равных первому в массиве  Но в случае если меняешь протягивание снизу вверх , то не выходит
 
Цитата
Странник123 написал:
Я с UDF еще не разу не работал....Что я делаю не так?  
Работа с UDF мало чем отличается от обычных формул. Для Вашего случая, если я правильно понял задачу, как-то так
=СУММЕСЛИМН(B1:B38;A1:A38;F1;C1:C38;">"&F2)
Согласие есть продукт при полном непротивлении сторон
Страницы: 1
Наверх