Страницы: 1
RSS
Подстановка по условию
 
Добрый день!
Подскажите пжл, есть ли формула для выполнения подстановки в ячейку I... по условию в ячейке С...?
Изменено: Кирилл Клыков - 08.07.2024 13:05:29
 
Не нужно вставлять картинку, лучше файл-пример (Excel!) приложите. Исправьте стартовое сообщение
Согласие есть продукт при полном непротивлении сторон
 
В файле кроме потока мыслей в столбце А больше ничего нет
 
А что получить-то нужно в итоге? Какой результат?
Согласие есть продукт при полном непротивлении сторон
 
Если в ячейке С3 "Оборудование, материалы, СМР/ПНР - сами", то в ячейке I8 - 1500
Если в ячейке С3 "Оборудование и материалы наши, СМР/ПНР делает подрядчик", то в ячейке I8 - 2000
и т.д.
 
Кирилл Клыков, в i8
Код
=HLOOKUP(C2;$E$7:$H$8;2;0)

где HLOOKUP по русски ГПР
Изменено: bigorq - 08.07.2024 13:34:53
 
Здравствуйте Кирилл Клыков
Так, что ли?
Код
=ГПР(J$7;E$7:H$11;СТРОКА(A2);)*D8
 
ТАК?

=ЕСЛИ($C$3="Оборудование, материалы, СМР/ПНР - сами"; 1500; ЕСЛИ($C$3="Оборудование и материалы наши, СМР/ПНР делает подрядчик"; 2000; ЕСЛИ($C$3="Оборудование наше, материалы, СМР/ПНР - подрядчик"; 2500; 3000)))
 
Цитата
написал:
А что получить-то нужно в итоге? Какой результат?
Покажите в файле, как должно быть.
Вложил файл с попыткой угадать конечный результат. Изменяйте текст в объединенной ячейке С2:F2.
Изменено: gling - 08.07.2024 14:44:11
 
=HLOOKUP(C2;$E$7:$H$8;2;0)

Отлично! Работает! Спасибо!

(Извините за задержку, в примере все упрощено, на самом в данных еще полно других столбцов. В итоге получился классный калькулятор с выпадающим списком варианта и пересчетом сводной)

Красота. Еще раз спасибо
Страницы: 1
Наверх