Страницы: 1
RSS
Вставка имени листа из соседней ячейки в формулу ВПР, Необходимо автоматизировать ВПР так, чтобы при протягивании в формуле менялись имена листов.
 
Предположим, в книге есть титульный лист, на который нужно вывести выборочно информацию с других листов.
Все листы имеют имена: 1,2,3,4,5 и т д
На каждом листе находится, например, пищевая ценность изделий. каждый лист - разное изделие.
На титульном листе я делаю формулу =ВПР("Белки";'1'!$A$2:$B$4;2;0) и эта формула возвращает мне значение из второго столбца строки с белками на листе с именем "1".
Имя нужного листа, при этом, у меня есть в соседней ячейке.
Возможно ли вместо '1'! вставить номер листа из соседней ячейки? Чтобы при протягивании формулы вниз - имена листов брались из ячеек?
Пример во вложении.

Заранее благодарен!
 
Morio, вот так?
еще можно =ВПР(C$1;ДВССЫЛ("'"&$B2&"'!$A$2:$B$4");2;0), тут как удобнее. коллеги по форуму могут еще подсказать)
Изменено: zay_senya_z - 10.07.2024 12:09:46
 
Да! прекрасно работает! Очень благодарен!  :)  
Страницы: 1
Наверх